net-libs/zeromq: Restore parallel test restriction
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 4 Nov 2016 02:41:27 +0000 (03:41 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 4 Nov 2016 02:41:52 +0000 (03:41 +0100)
The parallel test restriction (-j1) was lost when the ebuild was bumped to
EAPI=6 but is still required.

Gentoo-Bug: https://bugs.gentoo.org/597808

Package-Manager: portage-2.3.2

net-libs/zeromq/zeromq-4.1.5-r1.ebuild
net-libs/zeromq/zeromq-4.1.6.ebuild

index 6dc347309e2092858651878de12139adc0990826..4101a7ee77712bd21eedea0c6d30477c153120e1 100644 (file)
@@ -43,6 +43,13 @@ src_configure() {
        econf "${myeconfargs[@]}"
 }
 
+src_test() {
+       # Restricting to one job because multiple tests are using the same port.
+       # Upstream knows the problem and says it doesn't support parallel test
+       # execution, see ${S}/INSTALL.
+       emake -j1 check
+}
+
 src_install() {
        default
        prune_libtool_files
index 6dc347309e2092858651878de12139adc0990826..4101a7ee77712bd21eedea0c6d30477c153120e1 100644 (file)
@@ -43,6 +43,13 @@ src_configure() {
        econf "${myeconfargs[@]}"
 }
 
+src_test() {
+       # Restricting to one job because multiple tests are using the same port.
+       # Upstream knows the problem and says it doesn't support parallel test
+       # execution, see ${S}/INSTALL.
+       emake -j1 check
+}
+
 src_install() {
        default
        prune_libtool_files