Version bump
authorMichael Cummings <mcummings@gentoo.org>
Sun, 22 Apr 2007 14:16:41 +0000 (14:16 +0000)
committerMichael Cummings <mcummings@gentoo.org>
Sun, 22 Apr 2007 14:16:41 +0000 (14:16 +0000)
Package-Manager: portage-2.1.2.3

12 files changed:
perl-core/CGI/CGI-3.29.ebuild [new file with mode: 0644]
perl-core/CGI/ChangeLog
perl-core/CGI/files/digest-CGI-3.29 [new file with mode: 0644]
perl-core/Math-BigInt/ChangeLog
perl-core/Math-BigInt/Math-BigInt-1.83.ebuild [new file with mode: 0644]
perl-core/Math-BigInt/files/digest-Math-BigInt-1.83 [new file with mode: 0644]
perl-core/Math-BigRat/ChangeLog
perl-core/Math-BigRat/Math-BigRat-0.19.ebuild [new file with mode: 0644]
perl-core/Math-BigRat/files/digest-Math-BigRat-0.19 [new file with mode: 0644]
perl-core/bignum/ChangeLog
perl-core/bignum/bignum-0.21.ebuild [new file with mode: 0644]
perl-core/bignum/files/digest-bignum-0.21 [new file with mode: 0644]

diff --git a/perl-core/CGI/CGI-3.29.ebuild b/perl-core/CGI/CGI-3.29.ebuild
new file mode 100644 (file)
index 0000000..b6a9f69
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/CGI-3.29.ebuild,v 1.1 2007/04/22 14:16:41 mcummings Exp $
+
+inherit perl-module
+
+myconf="INSTALLDIRS=vendor"
+MY_P=${PN}.pm-${PV}
+DESCRIPTION="Simple Common Gateway Interface Class"
+HOMEPAGE="http://search.cpan.org/~lds/"
+SRC_URI="mirror://cpan/authors/id/L/LD/LDS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+SRC_TEST="do"
index 6c7bdb76582231dcae06619b53779b1a1f4dc61e..e0df459aa73ecb0b1493521df0b836db989f44cc 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for perl-core/CGI
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/ChangeLog,v 1.43 2007/04/17 18:26:21 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/CGI/ChangeLog,v 1.44 2007/04/22 14:16:41 mcummings Exp $
+
+*CGI-3.29 (22 Apr 2007)
+
+  22 Apr 2007; Michael Cummings <mcummings@gentoo.org> +CGI-3.29.ebuild:
+  Version bump
 
   17 Apr 2007; Gustavo Zacarias <gustavoz@gentoo.org> CGI-3.27.ebuild:
   Stable on sparc
diff --git a/perl-core/CGI/files/digest-CGI-3.29 b/perl-core/CGI/files/digest-CGI-3.29
new file mode 100644 (file)
index 0000000..dd79cbc
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 56375d59265df3f2dc500261f7be095d CGI.pm-3.29.tar.gz 237899
+RMD160 ee17aa1ffdc2a839ff8a6c341a71a37f3d01c95b CGI.pm-3.29.tar.gz 237899
+SHA256 5aaebda7fb5b40cec981b461221410a34593281ee96799eaa3a2d9abc1d57914 CGI.pm-3.29.tar.gz 237899
index 2c7020978176de13879f9ba11c3c716585731519..3f9ff71ccca73646b71e0aa98f3df6ba6e12ce10 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for perl-core/Math-BigInt
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.32 2007/04/17 19:13:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/ChangeLog,v 1.33 2007/04/22 14:13:19 mcummings Exp $
+
+*Math-BigInt-1.83 (22 Apr 2007)
+
+  22 Apr 2007; Michael Cummings <mcummings@gentoo.org>
+  +Math-BigInt-1.83.ebuild:
+  Version bump
 
   17 Apr 2007; Gustavo Zacarias <gustavoz@gentoo.org>
   Math-BigInt-1.79.ebuild:
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.83.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.83.ebuild
new file mode 100644 (file)
index 0000000..d6a3d2d
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigInt/Math-BigInt-1.83.ebuild,v 1.1 2007/04/22 14:13:19 mcummings Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Arbitrary size floating point math package"
+HOMEPAGE="http://serach.cpan.org/~tels/"
+SRC_URI="mirror://cpan/authors/id/T/TE/TELS/math/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+               >=virtual/perl-Scalar-List-Utils-1.14"
+
+PDEPEND="perl-core/bignum
+               perl-core/Math-BigRat"
+
+SRC_TEST="do"
+PREFER_BUILDPL="no"
diff --git a/perl-core/Math-BigInt/files/digest-Math-BigInt-1.83 b/perl-core/Math-BigInt/files/digest-Math-BigInt-1.83
new file mode 100644 (file)
index 0000000..4ea680b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 8e9cf50a48aa16d611a7a1e22e37731b Math-BigInt-1.83.tar.gz 190172
+RMD160 357e4d9e6a19e5c1f99597001e35e47dd320c571 Math-BigInt-1.83.tar.gz 190172
+SHA256 e6232ecb42e599ae32094accd9f6152afcb11b4811bec709a19a0f44d6caf104 Math-BigInt-1.83.tar.gz 190172
index 6bfd466c7b47e09d919f3e909fa72c2daf3889fd..cd416fc02768f89c627ce07a845ff6a189004bc9 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for perl-core/Math-BigRat
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigRat/ChangeLog,v 1.7 2007/04/16 10:55:36 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigRat/ChangeLog,v 1.8 2007/04/22 14:14:39 mcummings Exp $
+
+*Math-BigRat-0.19 (22 Apr 2007)
+
+  22 Apr 2007; Michael Cummings <mcummings@gentoo.org>
+  +Math-BigRat-0.19.ebuild:
+  Version bump
 
 *Math-BigRat-0.18 (16 Apr 2007)
 
diff --git a/perl-core/Math-BigRat/Math-BigRat-0.19.ebuild b/perl-core/Math-BigRat/Math-BigRat-0.19.ebuild
new file mode 100644 (file)
index 0000000..e070517
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Math-BigRat/Math-BigRat-0.19.ebuild,v 1.1 2007/04/22 14:14:39 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Arbitrary big rational numbers"
+HOMEPAGE="http://search.cpan.org/~tels"
+SRC_URI="mirror://cpan/authors/id/T/TE/TELS/math/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+PREFER_BUILDPL="no"
+
+DEPEND=">=perl-core/Math-BigInt-1.83
+       dev-lang/perl"
diff --git a/perl-core/Math-BigRat/files/digest-Math-BigRat-0.19 b/perl-core/Math-BigRat/files/digest-Math-BigRat-0.19
new file mode 100644 (file)
index 0000000..8b4d16e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 cb93f194a4cf0c69b45858395033d149 Math-BigRat-0.19.tar.gz 47173
+RMD160 ec0267acf93c27b9fc73140fbd48be6a2e19be55 Math-BigRat-0.19.tar.gz 47173
+SHA256 7200633eeca786f560cdd1e2e8870e35a04cdc923bfd22e38e7feedd91897f1c Math-BigRat-0.19.tar.gz 47173
index 9dc5cc60e94f137e4b3dd60635e8a21205a820ec..6161fb57e815c9a38dc45435a77d79bb5b8c568d 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for perl-core/bignum
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/bignum/ChangeLog,v 1.8 2007/04/16 13:07:03 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/bignum/ChangeLog,v 1.9 2007/04/22 14:12:25 mcummings Exp $
+
+*bignum-0.21 (22 Apr 2007)
+
+  22 Apr 2007; Michael Cummings <mcummings@gentoo.org> +bignum-0.21.ebuild:
+  Version bump
 
   16 Apr 2007; Michael Cummings <mcummings@gentoo.org> bignum-0.20.ebuild:
   Updated IUSE for bignum-0.20
diff --git a/perl-core/bignum/bignum-0.21.ebuild b/perl-core/bignum/bignum-0.21.ebuild
new file mode 100644 (file)
index 0000000..762ff1c
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/bignum/bignum-0.21.ebuild,v 1.1 2007/04/22 14:12:25 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Transparent BigNumber/BigRational support for Perl"
+HOMEPAGE="http://search.cpan.org/~tels"
+SRC_URI="mirror://cpan/authors/id/T/TE/TELS/math/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+SRC_TEST="do"
+PREFER_BUILDPL="no"
+
+DEPEND=">=perl-core/Math-BigInt-1.83
+       >=perl-core/Math-BigRat-0.18
+       test? ( >=dev-perl/Test-Pod-Coverage-1.08 )
+       dev-lang/perl"
diff --git a/perl-core/bignum/files/digest-bignum-0.21 b/perl-core/bignum/files/digest-bignum-0.21
new file mode 100644 (file)
index 0000000..68fba52
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 090532fad1dec171da009688dae3cd4e bignum-0.21.tar.gz 27397
+RMD160 6cfbddc27fc83a917084f2eab8f233069753688c bignum-0.21.tar.gz 27397
+SHA256 b6b43bba4ea326baf13fe299b2f3aab3224dde9b773a206ba1d6c172b5f7c374 bignum-0.21.tar.gz 27397