dev-python/pypiserver: Bump to 1.3.2
authorMichał Górny <mgorny@gentoo.org>
Thu, 28 May 2020 07:05:39 +0000 (09:05 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 28 May 2020 07:05:55 +0000 (09:05 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pypiserver/Manifest
dev-python/pypiserver/pypiserver-1.3.2.ebuild [new file with mode: 0644]

index 72fb33b19973cf1bffb25e5aa4ef6214f9f61ab7..8f1de04c7b8ca66a11ffd7eaa214d51dad1d7129 100644 (file)
@@ -1 +1,2 @@
 DIST pypiserver-1.3.1.tar.gz 504875 BLAKE2B 18089a1d18ace55038fb2b114a3402ce1352139a858a2e32399ad36ef0cbe5dfcf9bbdb865807ea84330405bdd4da1c00265e095b7299fe2b9f56150d573f7d9 SHA512 425a557eb74111fb07911cacd275dfa35b8e8ba5e9f230ca5f86500c10b2ab33235eb3376150c75972de3d8ebd85b03ecdf935753b0af46936a78311d5f174a7
+DIST pypiserver-1.3.2.tar.gz 505905 BLAKE2B 4e62d11cf280524d532e793d3ffc4dc59f1e72c6aba2ed6bd0d70f86104162dc60377b56e08676ab03326c33885acae698dc60b435426b195f13bf9f60bb7b8c SHA512 de823376f7711bfdaff3a1acefae37e1d7528802203929b8aeb8790c2b1c466badaf5a1d5084100bc37f41636d2cdfc2038cd3ad9805d15ca42c80834760b4da
diff --git a/dev-python/pypiserver/pypiserver-1.3.2.ebuild b/dev-python/pypiserver/pypiserver-1.3.2.ebuild
new file mode 100644 (file)
index 0000000..09770ec
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Minimal PyPI server"
+HOMEPAGE="https://github.com/pypiserver/pypiserver"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+       dev-python/pip[${PYTHON_USEDEP}]
+       >=dev-python/wheel-0.25.0[${PYTHON_USEDEP}]"
+BDEPEND="
+       dev-python/setuptools-git[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/passlib[${PYTHON_USEDEP}]
+               >=dev-python/pytest-2.3[${PYTHON_USEDEP}]
+               dev-python/twine[${PYTHON_USEDEP}]
+               dev-python/webtest[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+       )"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+       sed -i -e "/tox/d" setup.py || die
+
+       # https://github.com/pypiserver/pypiserver/issues/312
+       sed -e 's:test_root_count:_&:' \
+               -i tests/test_app.py || die
+       sed -e 's:test_hash_algos:_&:' \
+               -e 's:test_pipInstall_openOk:_&:' \
+               -e 's:test_pipInstall_authedOk:_&:' \
+               -i tests/test_server.py || die
+
+       distutils-r1_src_prepare
+}