dev-python/python-msrplib: initial import of version 0.18.0
authorJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 01:18:53 +0000 (03:18 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 17:40:15 +0000 (19:40 +0200)
Gentoo-Bug: 446194

dev-python/python-msrplib/Manifest [new file with mode: 0644]
dev-python/python-msrplib/metadata.xml [new file with mode: 0644]
dev-python/python-msrplib/python-msrplib-0.18.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-msrplib/Manifest b/dev-python/python-msrplib/Manifest
new file mode 100644 (file)
index 0000000..bebf1f0
--- /dev/null
@@ -0,0 +1 @@
+DIST python-msrplib-0.18.0.tar.gz 30234 SHA256 72901c42cf05262890e3bb5ae37364f074632d067f139a8f71e395006e79e96e SHA512 ed260b0183aff543e115951f464d0e3934862439a7c049c3d19304c543805ee364129d2a99c0d132561c8ae0af9fc19cde460723f2754e973bf68a602a18db99 WHIRLPOOL b5edc6f87546173c384452ff1636b5d61a6ac893026362fbfd039a5c80b2fdd887f3eac1220db4843b85889be83658ac46ae5535247aaac2cd63385af03afee5
diff --git a/dev-python/python-msrplib/metadata.xml b/dev-python/python-msrplib/metadata.xml
new file mode 100644 (file)
index 0000000..5ea4fe9
--- /dev/null
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+       <longdescription lang="en">
+               Message Session Relay Protocol (MSRP) is a protocol for transmitting a
+               series of related instant messages in the context of a session. Message
+               sessions are treated like any other media stream when set up via a
+               rendezvous or session creation protocol such as the Session Initiation
+               Protocol (SIP).
+
+               A series of related instant messages between two or more parties can be
+               viewed as part of a "message session", that is, a conversational exchange
+               of messages with a definite beginning and end. This is in contrast to
+               individual messages each sent independently. Messaging schemes that track
+               only individual messages can be described as "page-mode" messaging,
+               whereas messaging that is part of a "session" with a definite start and
+               end is called "session-mode" messaging.
+
+               Page-mode messaging is enabled in SIP via the SIP MESSAGE method, as
+               defined in RFC 3428. Session-mode messaging has a number of benefits
+               over page-mode messaging, however, such as explicit rendezvous, tighter
+               integration with other media-types, direct client-to-client operation,
+               and brokered privacy and security.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild b/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild
new file mode 100644 (file)
index 0000000..6ca282d
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for MSRP protocol and its relay extension"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/MSRP/python-msrplib-${PV}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/python-application[${PYTHON_USEDEP}]
+       dev-python/python-eventlib[${PYTHON_USEDEP}]
+       dev-python/python-gnutls[${PYTHON_USEDEP}]
+       dev-python/twisted-core[${PYTHON_USEDEP}]
+       dev-python/twisted-names[${PYTHON_USEDEP}]
+"