app-misc/tmate: version bump, 2.4.0
authorYixun Lan <dlan@gentoo.org>
Thu, 12 Dec 2019 05:51:10 +0000 (05:51 +0000)
committerYixun Lan <dlan@gentoo.org>
Thu, 12 Dec 2019 05:53:23 +0000 (05:53 +0000)
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Yixun Lan <dlan@gentoo.org>
app-misc/tmate/Manifest
app-misc/tmate/tmate-2.4.0.ebuild [new file with mode: 0644]

index bc657811867bba1eebf8bfe5f5acd1b1e942517b..c3c91f7c9be3a0d617b55bba58c20e1cf04294bd 100644 (file)
@@ -1,2 +1,3 @@
 DIST tmate-2.3.0.tar.gz 611262 BLAKE2B c4e789b20fbfb1736eacbf36f368d8ceb573937ed2c72f2b79b8da175a811985af12d9823fdbade9ee3f72bfb43427e8fa64eea75ba5fc3cf64273c31856d4d6 SHA512 b7de8f28ab5ee8ea389d4882ed64de3d71bd53d626ae6bf323d5be732066e63a7dba2a85318c0202a088af53df7e0d976256c1253895ad81739d270ee65d0eb7
 DIST tmate-2.3.1.tar.gz 611136 BLAKE2B bbcfb137cb9e712bbe3c36b2d57e6f1ea5a68c884e6e6ccd252315bca689b1bbec7a53cd131f0f36a6bab5b1defd3acb26bb458684894c81d676d2585db4790b SHA512 98531e3a3c1cc4da11894e8298df560fd58f1ede6a81ac8cb5f8cbea86f5c21672a016977dab801ec06e14f6c718a64599a9e32740934fcd4c0a155f92710520
+DIST tmate-2.4.0.tar.gz 614179 BLAKE2B 9864f71255ceafb10cfd622346ef7d2db2a124d13599a7c8ae81e83950ba56216193e02633a9becd90fd430c6ddff66df763fe2733d58f45b02c74c8fb8f7fc4 SHA512 92d2ca354b295678bfc2747ca83a45ebafeaec40ebac94bd94c4926af4f820b3f3a087f365147f41c80d1c8ad032f52c697a2421839c39315d84f98f7eccada6
diff --git a/app-misc/tmate/tmate-2.4.0.ebuild b/app-misc/tmate/tmate-2.4.0.ebuild
new file mode 100644 (file)
index 0000000..bdddbdf
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Instant terminal sharing"
+HOMEPAGE="https://tmate.io/"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libressl static-libs"
+
+SRC_URI="https://github.com/tmate-io/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="
+       sys-libs/zlib[static-libs?]
+       sys-libs/libutempter[static-libs?]
+       dev-libs/libevent[static-libs?]
+       dev-libs/msgpack[static-libs?]
+       >=net-libs/libssh-0.6.0[static-libs?]
+       !libressl? ( dev-libs/openssl:0=[static-libs?] )
+       libressl? ( dev-libs/libressl:0=[static-libs?] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable debug)
+       )
+       econf "${myeconfargs[@]}"
+}