net-fs/davfs2: prevent the compression of man for all supported langs
authorGöktürk Yüksek <gokturk@gentoo.org>
Wed, 6 May 2020 01:25:09 +0000 (21:25 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Wed, 6 May 2020 01:26:54 +0000 (21:26 -0400)
Package-Manager: Portage-2.3.69, Repoman-2.3.14
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
net-fs/davfs2/davfs2-1.5.6-r1.ebuild [moved from net-fs/davfs2/davfs2-1.5.6.ebuild with 87% similarity]

similarity index 87%
rename from net-fs/davfs2/davfs2-1.5.6.ebuild
rename to net-fs/davfs2/davfs2-1.5.6-r1.ebuild
index 6f227c812123f66a36dd78bbb41bd9bf6e58786b..1786c1a079aeb87e14f2d97283239401205dd95b 100644 (file)
@@ -27,9 +27,12 @@ RDEPEND="${RDEPEND}
 "
 
 src_prepare() {
+       local f
+
        # Let the package manager handle man page compression
-       sed -e '/^manual[58]_DATA/ s/\.gz//g' \
-               -i "${S}"/man/Makefile.in || die
+       while IFS="" read -d $'\0' -r f ; do
+               sed -e '/^manual[58]_DATA/ s/[.]gz//g' -i "${f}" || die
+       done < <(find "${S}"/man -type f -name 'Makefile.in' -print0)
 
        eapply "${FILESDIR}"/${PN}-1.5.5-gcc-10.patch \
                   "${FILESDIR}"/${P}-neon31-support.patch