dev-lua/lua_cliargs: version bump to 3.0-2
authorVictor Payno <vpayno+gentoo@gmail.com>
Fri, 24 Jan 2020 23:22:45 +0000 (15:22 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 16 Mar 2020 00:01:56 +0000 (17:01 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14437
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lua/lua_cliargs/Manifest
dev-lua/lua_cliargs/lua_cliargs-3.0_p2.ebuild [new file with mode: 0644]

index b397d8d960fad3f70513b80397e733c3013c0dcc..59c7b81278c164e2f555d3055744e120d55a26f1 100644 (file)
@@ -1,2 +1,3 @@
 DIST lua_cliargs-2.5_p5.tar.gz 19513 BLAKE2B 25cdfd9e96fd0cf5d600394c47ec53dd80e619dac8a37a40e22366e1090ffc9f9f250d71683140959fbd33b3983a759c931c3ac70a3f14e9556005fe5f82f72c SHA512 7c4d490f5d86b07bdf299c976b99bf83c9ba86fabeb321f348587f8ad207983292e3e9268ef72f3cc6ff9d6e32a43669de1d3c21c47499852f971c2cc2a4e746
 DIST lua_cliargs-3.0_p1.tar.gz 29904 BLAKE2B 4cb3e33c0d1331cb9c6cef9b8db67c12cfd3678277e11b6218d56ae38e4678dd48472d65dd959b59bb44d5c42c1e64697fe4e54b67e80933ab706d9d2b01c79f SHA512 2bdcd3c790a82351df598cb3d289de980fe771222ebd9715036678eecdbe51b7563d24629afa4d286b900d722bf844004d12f2330744a1e644d9286ac44b4dbe
+DIST lua_cliargs-3.0_p2.tar.gz 30435 BLAKE2B 8edf60870e0d91593064876a225ef7fbe638425da13b458d6356eaa0636482ca904f9355fd15314d4893e6f5346a6faa30fb6078d191a29aa14e26aa5d74a4be SHA512 e7a475f1d41249b0a35f021a6ccca46078f5b689c1927a4dd4cab80b2e4d291babaab35cf7d64fad3ebf68d871fb5177f030c7a2b28d9f55fbeb4dd26021d024
diff --git a/dev-lua/lua_cliargs/lua_cliargs-3.0_p2.ebuild b/dev-lua/lua_cliargs/lua_cliargs-3.0_p2.ebuild
new file mode 100644 (file)
index 0000000..e70979d
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="3.0-2"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND=">=dev-lang/lua-5.1:="
+RDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+       insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+       doins -r src/cliargs.lua src/cliargs
+
+       einstalldocs
+
+       if use doc; then
+               dodoc -r examples
+               docinto html
+               dodoc -r doc/*
+       fi
+}