dev-libs/appstream-glib: bump to 0.7.14, move to USE=gtk-doc
authorMart Raudsepp <leio@gentoo.org>
Wed, 13 Feb 2019 22:52:41 +0000 (00:52 +0200)
committerMart Raudsepp <leio@gentoo.org>
Wed, 13 Feb 2019 22:53:19 +0000 (00:53 +0200)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/appstream-glib/Manifest
dev-libs/appstream-glib/appstream-glib-0.7.14.ebuild [new file with mode: 0644]

index 5ac9a0b1cf25dca27eb422b183551f4263b76ef1..5ef5563c926b07b85106105c43f5d6f9298de182 100644 (file)
@@ -1 +1,2 @@
+DIST appstream-glib-0.7.14.tar.xz 2239240 BLAKE2B d99788b3349df6f40c5dd3d5a6fb90446d1885569c04aedde9848f41916a1407f8397c416e34e87164bad2fa2e71bc93849901b829e71839d0aa1911ca73e485 SHA512 b2b01e529032a684b7864d6c330e9cbefdfe6a4312dc5d2cde8cbe82875218a0d4dc92a4c3129e45605571ab77482a86470d7336c360a0070ea029a1090a60d5
 DIST appstream-glib-0.7.9.tar.xz 2245728 BLAKE2B fb6f54329bed91f1acaa6218b111fd4527dff7ed412a89cb44a6e4f6cdfb7e0fe4e6f9fb37b6cdc2efa75164dccef323b6d7428a63b08369b941d36b0b9071f0 SHA512 d78cb6f11cad01d67cb33f16e987485177d20b78a8b21cfbabb64ce7b18b813c0d2d1de2faeea199fdc31d12633e899a5596a6cf133cb831a4377d641f79eb7d
diff --git a/dev-libs/appstream-glib/appstream-glib-0.7.14.ebuild b/dev-libs/appstream-glib/appstream-glib-0.7.14.ebuild
new file mode 100644 (file)
index 0000000..9a5b5da
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="gtk-doc +introspection stemmer"
+
+RDEPEND="
+       >=dev-libs/glib-2.45.8:2
+       sys-apps/util-linux
+       app-arch/libarchive
+       >=net-libs/libsoup-2.51.92:2.4
+       >=dev-libs/json-glib-1.1.2
+       >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+
+       x11-libs/gtk+:3
+       >=media-libs/freetype-2.4:2
+       >=media-libs/fontconfig-2.11:1.0
+       dev-libs/libyaml
+       stemmer? ( dev-libs/snowball-stemmer )
+       x11-libs/pango
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+       dev-util/gperf
+
+       dev-libs/libxml2:2
+       app-text/docbook-xml-dtd:4.2
+       dev-libs/libxslt
+       gtk-doc? (
+               >=dev-util/gtk-doc-1.9
+               app-text/docbook-xml-dtd:4.3
+       )
+       >=sys-devel/gettext-0.19.7
+"
+# ${PN} superseeds appdata-tools
+RDEPEND="${RDEPEND}
+       !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+       local emesonargs=(
+               -Ddep11=true
+               -Dbuilder=true
+               -Drpm=false
+               -Dalpm=false
+               -Dfonts=true
+               $(meson_use stemmer)
+               -Dman=true
+               $(meson_use gtk-doc)
+               $(meson_use introspection)
+       )
+       meson_src_configure
+}