dev-ruby/curb: cleanup
authorHans de Graaff <graaff@gentoo.org>
Fri, 2 Feb 2018 17:07:46 +0000 (18:07 +0100)
committerHans de Graaff <graaff@gentoo.org>
Fri, 2 Feb 2018 17:07:46 +0000 (18:07 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-ruby/curb/Manifest
dev-ruby/curb/curb-0.9.3.ebuild [deleted file]

index 1043954706e7b6dd41b4e1b594021147f7185f4d..b83a0ac3ea7160cadaffbb0827545b0f8a9f7a16 100644 (file)
@@ -1,2 +1 @@
-DIST curb-0.9.3.gem 81920 BLAKE2B c7be8fb197d09b75a048384a59c2ea4b71363016848786764a1de267472136474d5a733abf18827c3e5bf5b459aeaad543b946dafcd30bc216503cf34b244a28 SHA512 b484505fbdd038f6827aec9fa936f0a00d0ada5af4c655320976b5efef2b0d503a1aae4f72246467ba7caaede1440c59f511f45f10c53b90fc2a94630bc620f9
 DIST curb-0.9.4.gem 82432 BLAKE2B 2bf2bf0d887369c484d246771afc9cb34c6eb72a3809f13c9047f82030d79b1be47141db03659c1e4f42792c94094e40f05d4b1b0d984aed73a47c24ef96379a SHA512 7b81ba587ac9beb203e040234d9f5032d87352a3e045d3705f474d2eaf1f620245240a59894c7147f54d55f0293f60488e8f883367f96945d49ffcdcef42bfc1
diff --git a/dev-ruby/curb/curb-0.9.3.ebuild b/dev-ruby/curb/curb-0.9.3.ebuild
deleted file mode 100644 (file)
index bb74e10..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
-       # fix tests when localhost is also ::1
-       sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
-       # avoid tests making outside network connections
-       rm tests/bug_postfields_crash.rb || die
-       sed -e '/test_easy_http_verbs_must_respond_to_str/,/^  end/ s:^:#:' \
-               -i tests/tc_curl_easy.rb || die
-
-       # avoid failing tests where failure condition seems weird, no 
-       # upstream travis so not clear if the test is indeed broken.
-       sed -i -e '/test_multi_easy_http/,/^  end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
-       ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
-       emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
-       cp -l ext/curb_core$(get_modname) lib || die
-}