dev-ros/ament_cmake_core: add live ebuild
authorAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 12:39:04 +0000 (13:39 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 12:39:04 +0000 (13:39 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild
dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild [new file with mode: 0644]

index 3641f1c485484b8728dccdf20935e17b19073a74..cd95fc719ffebac7c617d102b487359f1a6536a7 100644 (file)
@@ -8,13 +8,26 @@ PYTHON_COMPAT=( python{3_6,3_7} )
 inherit cmake-utils python-r1
 
 ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+       SRC_URI=""
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+       S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
 DESCRIPTION="The core of the ament buildsystem in CMake"
 HOMEPAGE="https://github.com/ament/ament_cmake"
-SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
 IUSE=""
 
 DEPEND="
@@ -25,7 +38,6 @@ DEPEND="
 RDEPEND="${DEPEND}"
 BDEPEND="${DEPEND}"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
 
 src_configure() {
        # This is a build tool that does not install python-related files
diff --git a/dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild b/dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild
new file mode 100644 (file)
index 0000000..cd95fc7
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+       SRC_URI=""
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+       S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The core of the ament buildsystem in CMake"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+       dev-python/ament_package[${PYTHON_USEDEP}]
+       dev-python/catkin_pkg[${PYTHON_USEDEP}]
+       ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+       # This is a build tool that does not install python-related files
+       # ... but we need to propagate the deps and use python3 to build it.
+       local pyimpl="${PYTHON_COMPAT[0]}"
+       python_export "${pyimpl}" EPYTHON PYTHON
+       python_wrapper_setup
+       cmake-utils_src_configure
+}