dev-python/batinfo: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 5 Aug 2018 13:27:10 +0000 (15:27 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 5 Aug 2018 13:53:01 +0000 (15:53 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/batinfo/Manifest
dev-python/batinfo/batinfo-0.4.2.ebuild [new file with mode: 0644]

index c2c8e10f1ff2a21e904aa99d50d6b500e8f2c413..b07b8fe2095f6b792409ba5ac95f8db4893302ca 100644 (file)
@@ -1 +1,2 @@
 DIST batinfo-0.3.tar.gz 3951 BLAKE2B 11360a3322866b084294b930569d3c2e424b8bb56e0484aba81085b68707287ad7be9a65b0bf5188c030384d70fbbefd30886ef73d03e7c29801a0e5ce49a3d8 SHA512 822e8e70f14a7f08713028ebc8b41aef6d9256984a6a381af11e5b36980a355636bc21d8b21753f4dabd20e38becf6152c623134a65109593ccba019afe3f3f3
+DIST batinfo-0.4.2.tar.gz 6497 BLAKE2B 24efbd63f25bbd743e02ea04bf656d24b3132b6ce7e2754359a84648c357fb40967c3bb2a0aa27a3938489f2fb64c9b712718c8a5ede0869f83a19eaa82a74e1 SHA512 c45232cdd79d2d10d814019bbfc167ef54c3d970c74320a5a007d3b603e62fbdfeaf53f88074cf53a7865293181707e2e63e5a565219c094a77be2adc5d53876
diff --git a/dev-python/batinfo/batinfo-0.4.2.ebuild b/dev-python/batinfo/batinfo-0.4.2.ebuild
new file mode 100644 (file)
index 0000000..28cd559
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple Python lib to retreive battery information"
+HOMEPAGE="https://github.com/nicolargo/batinfo https://pypi.org/project/batinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="
+       ${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"