media-plugins/kodi-pvr-hts: 4.4.20 version bump
authorCraig Andrews <candrews@gentoo.org>
Sun, 27 Oct 2019 18:56:40 +0000 (14:56 -0400)
committerCraig Andrews <candrews@gentoo.org>
Sun, 27 Oct 2019 19:05:29 +0000 (15:05 -0400)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-pvr-hts/Manifest
media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.20.ebuild [new file with mode: 0644]

index a0e8ea818bc783e5ad3a69f780882dc6203ec7b6..1f4857dfc96aa1415d9cbda19dd8a923afddc4de 100644 (file)
@@ -4,3 +4,4 @@ DIST kodi-pvr-hts-4.4.14.tar.gz 160561 BLAKE2B dda8728a411b95039a4132e2ca4c882e3
 DIST kodi-pvr-hts-4.4.16.tar.gz 160594 BLAKE2B 5ae9bff9ec9460c860b6333f93748d70c18987f51adf248482c2125610ea5a034f2d00312722b4d86d6435f5679e110451f1b6fc9743ed4c4cf79cb079d8f287 SHA512 f2e7ebdfa18f0b191b32964c18782ce0ee76497b141057c29aedb555dac932b1099aff319f4de61166f3fe7e1ab58b723acd2e1f284745f42d6174e7f3e8a31e
 DIST kodi-pvr-hts-4.4.17.tar.gz 161495 BLAKE2B 494d63cd77d6ada7090418140e7aebdb678941236fe45fc46464b213090a2cb5e386d0a59b589afc36cc4cbe020bd3205341b6d893de61c106aee55747172e18 SHA512 0c9eeb8194e4c5b54d5d4df86dc794604d8df91ef172eff9207001ece9a485f7eea40ece449c28bb4cbb414a5a195e6fc50b9571744420c76da104f5fadff377
 DIST kodi-pvr-hts-4.4.18.tar.gz 161525 BLAKE2B 22d869989fc2151ca5ec39c7802d4612d2dcf5e29065bb27a45f528b939f94835585a6a5d427c29a79bea31f5cae811e450be6d80a30d0a18d6934eb63eff395 SHA512 1a0fd0fdec46178262c3f03544d02d13601858043d58ff71bae97c60514f3b11edf12fa53e4436a0de13dcb6877e937d37a5a02f7d6b9ebebbcec9c39e357ce9
+DIST kodi-pvr-hts-4.4.20.tar.gz 161693 BLAKE2B d69e72c8d189b540f2d8abc97c50e5a9e93346823333fe2441d3f7b625b94de72dfe50f6e8af5d17506265746819fff1a3d1f1e06ba7b79934ce234151940525 SHA512 aa8ed5487fa00c7cdc13aa167f103daa2a2cbfd93da2414fa85a339edbca3dda056e1073d52bd3a752e00652e83e3c5ddd1de42741600b9da143b18557f598be
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.20.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.20.ebuild
new file mode 100644 (file)
index 0000000..5b0620a
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+       inherit git-r3
+else
+       CODENAME="Leia"
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =dev-libs/libplatform-2*
+       =media-libs/kodi-platform-18*
+       =media-tv/kodi-18*
+       "
+
+RDEPEND="
+       ${DEPEND}
+       "