app-emulation/libvirt: Only require USE=cgroup-hybrid for USE=lxc
authorMatthias Maier <tamiko@gentoo.org>
Tue, 3 Dec 2019 18:48:52 +0000 (12:48 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 3 Dec 2019 18:48:52 +0000 (12:48 -0600)
Reportedly version 5.8.0 should be fine with a cgroup v2 only hierarchy
(verified that on my own system for qemu). Unfortunately, we still need
the hybrid layout as a mitigation for a bug in the libvirt-lxc driver.

So restrict the dependency on sys-apps/systemd[cgroup-hybrid] to the
case of USE=lxc only. This should accomodate everyone who does not need
libvirt-lxc support and wants to have a v2 only hierarchy.

Upstream Bug: https://bugzilla.redhat.com/show_bug.cgi?id=1770763
Bug: https://bugs.gentoo.org/699758
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/libvirt/libvirt-5.8.0.ebuild
app-emulation/libvirt/libvirt-9999.ebuild

index 17eb6ffb24aaf72bf80384867db38ddd9465f5b0..d878aa6e027ee43f448157876fb190243a8847eb 100644 (file)
@@ -60,7 +60,6 @@ RDEPEND="
        net-libs/rpcsvc-proto
        >=net-misc/curl-7.18.0
        sys-apps/dmidecode
-       !sys-apps/systemd[-cgroup-hybrid(+)]
        >=sys-apps/util-linux-2.17
        sys-devel/gettext
        sys-libs/ncurses:0=
@@ -77,6 +76,7 @@ RDEPEND="
        iscsi-direct? ( >=net-libs/libiscsi-1.18.0 )
        libssh? ( net-libs/libssh )
        lvm? ( >=sys-fs/lvm2-2.02.48-r2[-device-mapper-only(-)] )
+       lxc? ( !sys-apps/systemd[-cgroup-hybrid(+)] )
        nfs? ( net-fs/nfs-utils )
        numa? (
                >sys-process/numactl-2.0.2
index 03d2e558566421e965e250cc16d51b06309af0ab..4191f89dc94a7ed759a9cfdcc2e3dba430504d8e 100644 (file)
@@ -61,7 +61,6 @@ RDEPEND="
        net-libs/rpcsvc-proto
        >=net-misc/curl-7.18.0
        sys-apps/dmidecode
-       !sys-apps/systemd[-cgroup-hybrid(+)]
        >=sys-apps/util-linux-2.17
        sys-devel/gettext
        sys-libs/ncurses:0=
@@ -78,6 +77,7 @@ RDEPEND="
        iscsi-direct? ( >=net-libs/libiscsi-1.18.0 )
        libssh? ( net-libs/libssh )
        lvm? ( >=sys-fs/lvm2-2.02.48-r2[-device-mapper-only(-)] )
+       lxc? ( !sys-apps/systemd[-cgroup-hybrid(+)] )
        nfs? ( net-fs/nfs-utils )
        numa? (
                >sys-process/numactl-2.0.2