build-sys: fix installation of files
authorFabian Groffen <grobian@gentoo.org>
Sun, 8 Jul 2012 16:58:35 +0000 (18:58 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sun, 8 Jul 2012 16:58:35 +0000 (18:58 +0200)
avoid using hash in the sed, the interaction of make with the shell
seems to interpret the hash somewhere, despite being quoted, resulting
in loss of half of the sed command

pym/Makefile.in

index ce8fa39206fedaba03e7ca29ff9b304977853838..f9a9636511f46850f6c01cb10f0206c978c64bd1 100644 (file)
@@ -16,14 +16,11 @@ PORTAGE_PYM = @PORTAGE_BASE@/pym
 INSTALL = @INSTALL@
 INSTALL_subst = ${top_builddir}/subst-install
 
-list_sourcedir_dirs = \
-       ( cd "$(srcdir)" && find . -name '.git' -prune -o -type d -print | sed 's#^./\?##' )
-
 all:
 
 install:
        $(INSTALL) -d -m 755 -o "$(portageuser)" -g "$(portagegroup)" $(DESTDIR)$(PORTAGE_PYM)
-       $(list_sourcedir_dirs) | while read f ; do \
+       ( cd "$(srcdir)" && find . -name '.git' -prune -o -type d -print | sed 's|^./\?||' ) | while read f ; do \
                $(INSTALL) -d -m 755 \
                        -o "$(portageuser)" -g "$(portagegroup)" \
                        "$(DESTDIR)$(PORTAGE_PYM)/$${f}" && \