dev-libs/libgweather: bump to 3.28.3
authorMart Raudsepp <leio@gentoo.org>
Sat, 23 Feb 2019 12:06:37 +0000 (14:06 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 23 Feb 2019 12:22:52 +0000 (14:22 +0200)
Default enable USE=vala now, as it is increasing required by applications
due to no pregenerated C in them with meson. Currently gnome-clocks already
requires it.

Bug: https://bugs.gentoo.org/665578
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/libgweather/Manifest
dev-libs/libgweather/files/3.28.3-meson-tweaks.patch [new file with mode: 0644]
dev-libs/libgweather/libgweather-3.28.3.ebuild [new file with mode: 0644]
profiles/package.mask

index 4165a29d828abda5dcc0e15e73bee7c81e113948..7a87154a71bc7ba91998a258ccce110130c97a6b 100644 (file)
@@ -1,2 +1,3 @@
 DIST libgweather-3.24.1.tar.xz 3350680 BLAKE2B 9265cb3c280446d5f380f62b60efb5578a7a401e3291d12e3824d8e7eacc582761226b0aaebb0439318bd48b9ad5429a1b6d89eb0220a82650c43be8aa337e2d SHA512 564464d7a18a8e0320871ea418b1163163941c950c5acea5ee65a087e44c4d81e019e2e3e4cb6751989f823cbb7c5691713d3dcef72aeaf6ff264e61b6f7b4b4
 DIST libgweather-3.26.2.tar.xz 3409528 BLAKE2B 1c5cdc7125aac8df95e97db8fa1d63bcb06865e70691621bc3a1c0ece2e602862cef9a2a5daa2ebbc5fa7eaefa32bf89507f1eef8fa4eeff294d43132e83fab4 SHA512 75b936f93814005b4317dcb51777036f589f343526428d9a74de96aac1badd4fe81c117184e2bff84a7a3078d6f2a2000e7b63f1e1d80f839b3513cc470fb25b
+DIST libgweather-3.28.3.tar.xz 2711240 BLAKE2B 9e55c32485401fa31e5ca5a824f239c373e41c2ef3a1d4442ba4512f102edadaa3452bdc4f4a445ea34e5e24cda23fbf6e1363da5bd49f70018b387f7450cf15 SHA512 7eb98f15b624090ba0959f4ee47c1a2317504a381829cebb949f4104ea9b5c2847a98f95de60a35c5bf1094e500041c53e1afdb265dd2f237bc49db8acbfd6f2
diff --git a/dev-libs/libgweather/files/3.28.3-meson-tweaks.patch b/dev-libs/libgweather/files/3.28.3-meson-tweaks.patch
new file mode 100644 (file)
index 0000000..83880e0
--- /dev/null
@@ -0,0 +1,107 @@
+From b7df88319847f3155bd0e2ea994cf66c01fc1732 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 23 Feb 2019 12:21:01 +0200
+Subject: [PATCH] build: Provide introspection option and don't build manual
+ tests
+
+---
+ libgweather/meson.build | 21 ++++++++++++++-------
+ meson.build             |  4 ++++
+ meson_options.txt       |  2 ++
+ 3 files changed, 20 insertions(+), 7 deletions(-)
+
+diff --git a/libgweather/meson.build b/libgweather/meson.build
+index 4d907b9..9ede9d0 100644
+--- a/libgweather/meson.build
++++ b/libgweather/meson.build
+@@ -65,6 +65,15 @@ lib_libgweather = shared_library('gweather-3',
+   install: true,
+ )
++libgweather_dep = declare_dependency(
++  sources: [gweather_enum_types[1]],
++  dependencies: deps_libgweather,
++  link_with: lib_libgweather,
++  include_directories: root_inc,
++)
++
++if get_option('introspection')
++
+ gweather_gir = gnome.generate_gir(lib_libgweather,
+   sources: introspection_sources,
+   dependencies: deps_libgweather,
+@@ -79,13 +88,6 @@ gweather_gir = gnome.generate_gir(lib_libgweather,
+   install: true,
+ )
+-libgweather_dep = declare_dependency(
+-  sources: [gweather_enum_types[1], gweather_gir],
+-  dependencies: deps_libgweather,
+-  link_with: lib_libgweather,
+-  include_directories: root_inc,
+-)
+-
+ if enable_vala
+   gnome.generate_vapi('gweather-3.0',
+     sources: gweather_gir[0],
+@@ -94,9 +96,11 @@ if enable_vala
+     install: true
+   )
+ endif
++endif
+ test_cargs = ['-DTEST_SRCDIR="@0@/"'.format(meson.current_source_dir())]
++if false
+ executable('test_locations',
+   ['test_locations.c'],
+   c_args: test_cargs,
+@@ -107,6 +111,7 @@ executable('test_locations_utc',
+   c_args: test_cargs,
+   dependencies: libgweather_dep,
+   install: false)
++endif
+ exe = executable('test_libgweather',
+   ['test_libgweather.c'],
+@@ -115,6 +120,7 @@ exe = executable('test_libgweather',
+   install: false)
+ test('test_named_timezones', exe)
++if false
+ executable('test_metar',
+   ['test_metar.c', gweather_c_sources],
+   c_args: test_cargs,
+@@ -125,3 +131,4 @@ executable('test_sun_moon',
+   c_args: test_cargs,
+   dependencies: libgweather_dep,
+   install: false)
++endif
+diff --git a/meson.build b/meson.build
+index 5b30864..2e9fa08 100644
+--- a/meson.build
++++ b/meson.build
+@@ -108,6 +108,10 @@ else
+   enable_vala = enable_vala != 'false'
+ endif
++if enable_vala and not get_option('introspection')
++  error('Vala bindings require introspection support')
++endif
++
+ root_inc = include_directories('.')
+ subdir('libgweather')
+diff --git a/meson_options.txt b/meson_options.txt
+index 19b2c6a..bf4c517 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -8,3 +8,5 @@ option('enable_vala', type: 'combo', choices : ['true', 'false', 'auto'], value
+        description: 'Install vala bindings')
+ option('gtk_doc', type: 'boolean', value: false,
+        description: 'Whether to generate the API reference')
++option('introspection', type: 'boolean', value: true,
++       description: 'generate GObject Introspection data')
+-- 
+2.17.0
+
diff --git a/dev-libs/libgweather/libgweather-3.28.3.ebuild b/dev-libs/libgweather/libgweather-3.28.3.ebuild
new file mode 100644 (file)
index 0000000..16dcb34
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-15" # subslot = 3-(libgweather-3 soname suffix)
+
+IUSE="glade gtk-doc +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+       >=dev-libs/glib-2.35.1:2
+       >=x11-libs/gtk+-3.13.5:3[introspection?]
+       >=net-libs/libsoup-2.44:2.4
+       >=dev-libs/libxml2-2.6.0:2
+       sci-geosciences/geocode-glib
+       >=sys-libs/timezone-data-2010k
+
+       glade? ( >=dev-util/glade-3.16:3.10 )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1.11
+               app-text/docbook-xml-dtd:4.3 )
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       $(vala_depend)
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PV}-meson-tweaks.patch # Provide introspection optionality and don't build tests that aren't ran automatically
+)
+
+src_prepare() {
+       xdg_src_prepare
+       vala_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use glade glade_catalog)
+               $(meson_use vala enable_vala)
+               $(meson_use gtk-doc gtk_doc)
+               $(meson_use introspection)
+       )
+       meson_src_configure
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}
index 3015e2be7aa985490dda93e9dce631da72bb625c..623acf72e3482db26258e9716328cadeccc12161 100644 (file)
@@ -36,6 +36,7 @@
 # better idea to just wait for a smaller set to be ready within a couple
 # days and quickly unmasked.
 >=gnome-base/gnome-desktop-3.30.2.1
+>=dev-libs/libgweather-3.28.3
 
 # Michał Górny <mgorny@gentoo.org> (13 Feb 2019)
 # Release candidate, masked for testing.