dev-ruby/whole_history_rating: new package
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>
Fri, 25 Oct 2019 09:43:31 +0000 (11:43 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 25 Oct 2019 10:00:41 +0000 (12:00 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13032
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-ruby/whole_history_rating/Manifest [new file with mode: 0644]
dev-ruby/whole_history_rating/metadata.xml [new file with mode: 0644]
dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/whole_history_rating/Manifest b/dev-ruby/whole_history_rating/Manifest
new file mode 100644 (file)
index 0000000..4da6326
--- /dev/null
@@ -0,0 +1 @@
+DIST whole_history_rating-0.1.2.gem 9728 BLAKE2B 506354634ab0390b7805e31ee1982309a903000b69a20992cfa53196da8e685b4ea1c89df7ed96ddd4fc5c8a8974d23dc48625d3e93ebbc09121b32e0ab7216e SHA512 4ee9a3340a5bbe1a0250b469c1210663ff226a1884d13729e169d2c04ef57c615bef117a641d6ac3b29b5d72147009149c291e1f7ad8c4c8028ad3e6fb44c56c
diff --git a/dev-ruby/whole_history_rating/metadata.xml b/dev-ruby/whole_history_rating/metadata.xml
new file mode 100644 (file)
index 0000000..38d2913
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>lssndrbarbieri@gmail.com</email>
+    <name>Alessandro Barbieri</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">goshrine/whole_history_rating</remote-id>
+  </upstream>
+  <longdescription lang="en">This gem provides a library and executables that take as input as set of games and output a set of skill rankings for the players of those games. The algorithm is a version of Remi Coulom's Whole-History Rating modified to support handicaps, and implemented in Ruby.
+  </longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..709e0ff
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+ruby_add_bdepend "
+       test? (
+               dev-ruby/test-unit:2
+       )
+"