app-text/wgetpaste: Version bump (v2.29)
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 14 Jun 2019 06:56:16 +0000 (09:56 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 14 Jun 2019 06:56:16 +0000 (09:56 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-text/wgetpaste/Manifest
app-text/wgetpaste/wgetpaste-2.29.ebuild [new file with mode: 0644]

index 957ed7adae8bffa28430a9645659d447ec810b45..1fd17fb5070bda672ae01d9721a921de0ca2ea51 100644 (file)
@@ -1 +1,2 @@
 DIST wgetpaste-2.28.tar.bz2 12448 BLAKE2B 231b6d00ecf9c355f45683d56537c0fe6a5d6561e42edee680b228f5a76e7e1b202669e429f7941b6daaf14682e5a8469521713930bb42387e168965acfccca2 SHA512 b3b9ee4bfbc52da6762b06c2640385eeedab7910ad1bc4e92ff9304371ec2442e2d30b69ebc0f1407a00a9c8afde398e00dc3d3c048452d730517227a68e6b97
+DIST wgetpaste-2.29.tar.bz2 12988 BLAKE2B 838b84632754f6e07c25fe3648e14bf939dff4e08ae8e8064e94008beb436f77738e4f54859115321fbf445a323641ebfecf5fd7d09bbbb46c72e913687deb07 SHA512 6596842733bb5d1d52cbb3cbcf61ba714f0cbfdc13acb4d6025ccfd27c214adaf886ac3a0a11baefaa4af3f33165619e5a3360b4e0807d29e8dc8ef5ff819bb6
diff --git a/app-text/wgetpaste/wgetpaste-2.29.ebuild b/app-text/wgetpaste/wgetpaste-2.29.ebuild
new file mode 100644 (file)
index 0000000..ff53674
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="http://wgetpaste.zlin.dk/"
+SRC_URI="http://wgetpaste.zlin.dk/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+ssl"
+
+DEPEND=""
+RDEPEND="net-misc/wget[ssl?]"
+
+src_prepare() {
+       sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+       default
+}
+
+src_install() {
+       dobin ${PN}
+       insinto /usr/share/zsh/site-functions
+       doins _wgetpaste
+}