media-libs/mesa: Drop building radv in 13.0.5.
authorMatt Turner <mattst88@gentoo.org>
Sat, 4 Mar 2017 16:18:10 +0000 (08:18 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sat, 4 Mar 2017 17:11:10 +0000 (09:11 -0800)
radv requires an unstable version of llvm (3.9).

media-libs/mesa/mesa-13.0.5.ebuild

index 83fa8ce7bd7c353ca72c6870a12894a52c231dff..060c3b35617da835948e9a0e153ec670b6305d9e 100644 (file)
@@ -56,8 +56,7 @@ REQUIRED_USE="
        gles2?  ( egl )
        vaapi? ( gallium )
        vdpau? ( gallium )
-       vulkan? ( || ( video_cards_i965 video_cards_radeonsi )
-                 video_cards_radeonsi? ( llvm ) )
+       vulkan? ( video_cards_i965 )
        wayland? ( egl gbm )
        xa?  ( gallium )
        video_cards_freedreno?  ( gallium )
@@ -97,7 +96,6 @@ RDEPEND="
        llvm? (
                video_cards_radeonsi? (
                        virtual/libelf:0=[${MULTILIB_USEDEP}]
-                       vulkan? ( >=sys-devel/llvm-3.9.0:0=[${MULTILIB_USEDEP}] )
                )
                >=sys-devel/llvm-3.6.0:0=[${MULTILIB_USEDEP}]
        )
@@ -276,7 +274,9 @@ multilib_src_configure() {
 
        if use vulkan; then
                vulkan_enable video_cards_i965 intel
-               vulkan_enable video_cards_radeonsi radeon
+
+               # radv is disabled due to dependence on >=llvm-3.9, bug 607660
+               #vulkan_enable video_cards_radeonsi radeon
        fi
 
        # x86 hardened pax_kernel needs glx-rts, bug 240956