net-misc/x11-ssh-askpass: EAPI 7, new maintainer
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>
Thu, 31 Oct 2019 22:30:18 +0000 (00:30 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 2 Nov 2019 08:52:24 +0000 (09:52 +0100)
Bug: https://bugs.gentoo.org/697224
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua>
Closes: https://github.com/gentoo/gentoo/pull/13512
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-misc/x11-ssh-askpass/metadata.xml
net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild [new file with mode: 0644]

index 6f49eba8f49693023f393161560b3a2d9e2717c5..344661c689f9f33cf9c09497ea811967710a3706 100644 (file)
@@ -1,5 +1,20 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>spiderx@spiderx.dp.ua</email>
+               <name>Vladimir Pavljuchenkov</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription lang="en">
+       This is an X11-based passphrase dialog for use with OpenSSH.
+       These dialogs are intended to be called from the ssh-add program
+       and not invoked directly.
+       </longdescription>
+       <upstream>
+               <remote-id type="github">sigmavirus24/x11-ssh-askpass</remote-id>
+       </upstream>
 </pkgmetadata>
diff --git a/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild b/net-misc/x11-ssh-askpass/x11-ssh-askpass-1.2.4.1-r2.ebuild
new file mode 100644 (file)
index 0000000..65224da
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="X11-based passphrase dialog for use with OpenSSH"
+HOMEPAGE="http://www.liquidmeme.net/software/x11-ssh-askpass
+       https://github.com/sigmavirus24/x11-ssh-askpass"
+SRC_URI="http://www.liquidmeme.net/software/x11-ssh-askpass/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/ssh
+       x11-libs/libXt
+       x11-libs/libX11
+       x11-libs/libSM
+       x11-libs/libICE"
+DEPEND="${RDEPEND}"
+BDEPEND="x11-misc/imake
+       app-text/rman"
+
+src_configure() {
+       econf --libexecdir=/usr/$(get_libdir)/misc \
+               --disable-installing-app-defaults
+       xmkmf || die "xmkmf failed"
+}
+
+src_compile() {
+       emake includes
+       emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}"
+}
+
+src_install() {
+       default
+       newman x11-ssh-askpass.man x11-ssh-askpass.1
+       dosym ../"$(get_libdir)"/misc/x11-ssh-askpass /usr/bin/x11-ssh-askpass
+}