media-gfx/darktable: Fix build with >=media-libs/exiv2-0.27.1
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 15 Sep 2019 23:04:26 +0000 (01:04 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 15 Sep 2019 23:05:43 +0000 (01:05 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/darktable/darktable-2.6.2.ebuild
media-gfx/darktable/files/darktable-2.6.2-exiv2-0.27.patch [new file with mode: 0644]

index e9bf1a97e402513263fb08abcb6a2a5ddab00836..c098e19ec2584ad546f2aaa40d60b0cb57ed8c5f 100644 (file)
@@ -72,6 +72,7 @@ RDEPEND="${COMMON_DEPEND}
 PATCHES=(
        "${FILESDIR}"/"${PN}"-find-opencl-header.patch
        "${WORKDIR}"/"${P}"-gcc9.patch
+       "${FILESDIR}"/"${P}"-exiv2-0.27.patch
 )
 
 S="${WORKDIR}/${P/_/~}"
diff --git a/media-gfx/darktable/files/darktable-2.6.2-exiv2-0.27.patch b/media-gfx/darktable/files/darktable-2.6.2-exiv2-0.27.patch
new file mode 100644 (file)
index 0000000..c0eb59b
--- /dev/null
@@ -0,0 +1,21 @@
+From 556887d7a973bdf0611fcc57231e107b503d9949 Mon Sep 17 00:00:00 2001
+From: Bertrand Antoine <nexus6b@gmail.com>
+Date: Wed, 22 May 2019 21:49:59 +0200
+Subject: [PATCH] Fix build with exif2 >= 0.27
+
+---
+ tools/basecurve/exif-wrapper.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tools/basecurve/exif-wrapper.cpp b/tools/basecurve/exif-wrapper.cpp
+index 72550721f6..f4d4d46e12 100644
+--- a/tools/basecurve/exif-wrapper.cpp
++++ b/tools/basecurve/exif-wrapper.cpp
+@@ -17,6 +17,7 @@
+ */
+ #include <exiv2/exif.hpp>
++#include <exiv2/error.hpp>
+ #include <exiv2/image.hpp>
+ #include <cstdio>
\ No newline at end of file