dev-python/elementpath: Bump to 1.4.5
authorMichał Górny <mgorny@gentoo.org>
Sat, 23 May 2020 06:02:57 +0000 (08:02 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 23 May 2020 06:11:31 +0000 (08:11 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/elementpath/Manifest
dev-python/elementpath/elementpath-1.4.5.ebuild [new file with mode: 0644]

index aa67267823296a9728428e61aa28450879a20b7f..cdbebaf677c743aa68e4778d23ee2df166c1567e 100644 (file)
@@ -1 +1,2 @@
 DIST elementpath-1.4.4.tar.gz 119577 BLAKE2B 65724afc715dcdb4903779933559e85c833cc262cecf2f53a86fd58e542717dc26137270bde13b5bdfcd81bb768a2dd74d7ed7213ad4292c0a1a2a4771855370 SHA512 39ce9f8e8f0a75690d5ccf5faa7e28113f971015c2baeec8b8f443b568c71154589d36dc2c5a3965eeb1d3d4257f65090cf44078747c7711bc7fc8c9ad051d43
+DIST elementpath-1.4.5.tar.gz 120091 BLAKE2B c9ac74c4b76b3a3204364532831563c5600bdc159cfe5e853852c08de0c7abbaec952304120da4f13b14d2239880c9c1612ae8db3535cf4ad1d8ea8498cc3f1a SHA512 be3908056af67f892696edd31d1c836bbd7083a96eca1217d2dc972c5fc3bc583d89b825bed3fedeebd775d5fca53dd9b9a918ff9a3238bba54efe8ac0a51e21
diff --git a/dev-python/elementpath/elementpath-1.4.5.ebuild b/dev-python/elementpath/elementpath-1.4.5.ebuild
new file mode 100644 (file)
index 0000000..fa02bf8
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="https://github.com/sissaschool/elementpath
+       https://pypi.org/project/elementpath/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/lxml[${PYTHON_USEDEP}]
+               dev-python/xmlschema[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests unittest