media-video/obs-studio: fix build with GCC-10
authorJimi Huotari <chiitoo@gentoo.org>
Sun, 10 May 2020 07:16:34 +0000 (10:16 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 10 May 2020 11:41:35 +0000 (13:41 +0200)
Bug: https://bugs.gentoo.org/708628
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/15736
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-video/obs-studio/files/obs-studio-25.0.8-gcc-10-build.patch [new file with mode: 0644]
media-video/obs-studio/obs-studio-25.0.8.ebuild

diff --git a/media-video/obs-studio/files/obs-studio-25.0.8-gcc-10-build.patch b/media-video/obs-studio/files/obs-studio-25.0.8-gcc-10-build.patch
new file mode 100644 (file)
index 0000000..352ea2c
--- /dev/null
@@ -0,0 +1,30 @@
+From c7f84f8fc4e90ef779a204ac268f5ee1a962e324 Mon Sep 17 00:00:00 2001
+From: Jimi Huotari <chiitoo@gentoo.org>
+Date: Sun, 9 Feb 2020 05:23:55 +0200
+Subject: [PATCH] deps/glad: Fix build with GCC-10
+
+GCC-10 defaults to '-fno-common' [1], which triggers issues with
+defining global variables multiple times.  To fix the build, use
+'extern' to turn the first definition of 'gladGetProcAddressPtr'
+into a declaration.
+
+1. https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85678
+
+Closes https://github.com/obsproject/obs-studio/issues/2828
+---
+ deps/glad/src/glad_glx.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/deps/glad/src/glad_glx.c b/deps/glad/src/glad_glx.c
+index 7c55b9fc01..58086f1039 100644
+--- a/deps/glad/src/glad_glx.c
++++ b/deps/glad/src/glad_glx.c
+@@ -35,7 +35,7 @@ static void* libGL;
+ #ifndef __APPLE__
+ typedef void* (APIENTRYP PFNGLXGETPROCADDRESSPROC_PRIVATE)(const char*);
+-PFNGLXGETPROCADDRESSPROC_PRIVATE gladGetProcAddressPtr;
++extern PFNGLXGETPROCADDRESSPROC_PRIVATE gladGetProcAddressPtr;
+ #endif
+ static
index 33ca63777c33718389fced5d9728b41bc63221f0..a97ec6617d4283a78bd1831c4a3642c2e15e3c07 100644 (file)
@@ -78,6 +78,8 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
+PATCHES=( "${FILESDIR}/${PN}-25.0.8-gcc-10-build.patch" )
+
 pkg_setup() {
        use python && python-single-r1_pkg_setup
 }