dev-python/spyder-terminal: version bump 0.3.2
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Fri, 1 May 2020 16:59:55 +0000 (18:59 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 16:24:48 +0000 (19:24 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/spyder-terminal/Manifest
dev-python/spyder-terminal/spyder-terminal-0.3.2.ebuild [new file with mode: 0644]

index 8aeae96dcf353291c504080e6f1ec9795f5b1179..d15c64f0f494fade739707e5fcfc8ae647ea37d0 100644 (file)
@@ -1 +1,2 @@
 DIST spyder-terminal-0.3.0.tar.gz 8396164 BLAKE2B 6fc185501f9a462f1a05f105394d13a89b669366e71bcce50984c90e3aa21d964fd2f19a56f7f33a1a80b5ff1f591d9d654d28df89a3dbc766557cea98e88c61 SHA512 88ff85c5cea984b54250bfe722c34d3c7008dac2ecb03aca219a127b9bd08352f8e467e09794b0ec3243f31ffbd7c5c51dc4b47ef277e0b5f78f3362a2f2a5ee
+DIST spyder-terminal-0.3.2.tar.gz 9063459 BLAKE2B 3682f8f4feb252959d7364482c1b8e20498c53b8a6d035d72ba0353fbcc09d19b2bc45e38c36c2e309170cbcb89d2ecf524e2b3d22b6fd4aeb1ee17334d3cc8b SHA512 72b092418b2240f0125dd38a1154fe80b400df1cd983d722240c866653bda2e578c679908c16b89aa78f8a022ff253aa45ef41721520646ceaecd798b9b1ecb4
diff --git a/dev-python/spyder-terminal/spyder-terminal-0.3.2.ebuild b/dev-python/spyder-terminal/spyder-terminal-0.3.2.ebuild
new file mode 100644 (file)
index 0000000..b95ea42
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Run system terminals inside Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-terminal"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/coloredlogs[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+       dev-python/terminado[${PYTHON_USEDEP}]
+       www-servers/tornado[${PYTHON_USEDEP}]
+"