dev-libs/cyrus-sasl: Bump to version 2.1.27
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 20 Nov 2018 10:58:18 +0000 (11:58 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 1 Jan 2019 16:05:46 +0000 (17:05 +0100)
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/10454
Closes: https://bugs.gentoo.org/592528
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-libs/cyrus-sasl/Manifest
dev-libs/cyrus-sasl/cyrus-sasl-2.1.27.ebuild [new file with mode: 0644]
dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-as_needed.patch [new file with mode: 0644]
dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-autotools_fixes.patch [new file with mode: 0644]
dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-avoid_pic_overwrite.patch [new file with mode: 0644]
dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-doc_build_fix.patch [new file with mode: 0644]
dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-gss_c_nt_hostbased_service.patch [new file with mode: 0644]

index 2d6baa82c815622041082f6280a0c55e10289b0a..5a11cc2bfebd45895ef7765292f1af6e0dc3de79 100644 (file)
@@ -1 +1,2 @@
 DIST cyrus-sasl-2.1.26.tar.gz 5220231 BLAKE2B 08fe5c1624e7cccb4b5e562f6987fddd047e1221b671cedbbb684d5a2f39e09a438ad14ffcedb5f398c203ca0b6e23574106c87f43a632028d50a69619c54970 SHA512 78819cb9bb38bea4537d6770d309deeeef09ff44a67526177609d3e1257ff4334d2b5e5131d5a1e4dea7430d8db1918ea9d171f0dee38b5e8337f4b72ed068f0
+DIST cyrus-sasl-2.1.27.tar.gz 4111249 BLAKE2B 82c9acce8534521ce5c5806f093e927f1854b4bc4b83ea7db1b32ceaa811adc1a5b6fc16d03233d729194cd603836f6e58de67f915abab2cb74561a80d03f5a8 SHA512 d11549a99b3b06af79fc62d5478dba3305d7e7cc0824f4b91f0d2638daafbe940623eab235f85af9be38dcf5d42fc131db531c177040a85187aee5096b8df63b
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.27.ebuild
new file mode 100644 (file)
index 0000000..09fe5b5
--- /dev/null
@@ -0,0 +1,251 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic multilib multilib-minimal autotools pam java-pkg-opt-2 db-use systemd eapi7-ver
+
+SASLAUTHD_CONF_VER="2.1.26"
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="https://www.cyrusimap.org/sasl/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-sasl/${P}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="authdaemond berkdb gdbm kerberos ldapdb libressl openldap mysql pam postgres sample selinux sqlite srp ssl static-libs urandom"
+
+CDEPEND="
+       net-mail/mailbase
+       authdaemond? ( || ( net-mail/courier-imap mail-mta/courier ) )
+       berkdb? ( >=sys-libs/db-4.8.30-r1:=[${MULTILIB_USEDEP}] )
+       gdbm? ( >=sys-libs/gdbm-1.10-r1:=[${MULTILIB_USEDEP}] )
+       kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+       openldap? ( >=net-nds/openldap-2.4.38-r1[${MULTILIB_USEDEP}] )
+       mysql? ( virtual/mysql )
+       pam? ( >=virtual/pam-0-r1[${MULTILIB_USEDEP}] )
+       postgres? ( dev-db/postgresql:* )
+       sqlite? ( >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}] )
+       ssl? (
+               !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+               libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+       )
+       java? ( >=virtual/jdk-1.6:= )"
+
+RDEPEND="
+       ${CDEPEND}
+       selinux? ( sec-policy/selinux-sasl )"
+
+DEPEND="${CDEPEND}
+       dev-perl/Pod-POM-View-Restructured
+       dev-python/sphinx"
+
+MULTILIB_WRAPPED_HEADERS=(
+       /usr/include/sasl/md5global.h
+)
+
+PATCHES=(
+       "${FILESDIR}/${PN}-2.1.27-avoid_pic_overwrite.patch"
+       "${FILESDIR}/${PN}-2.1.27-autotools_fixes.patch"
+       "${FILESDIR}/${PN}-2.1.27-as_needed.patch"
+       "${FILESDIR}/${PN}-2.1.25-auxprop.patch"
+       "${FILESDIR}/${PN}-2.1.27-gss_c_nt_hostbased_service.patch"
+       "${FILESDIR}/${PN}-2.1.26-missing-size_t.patch"
+       "${FILESDIR}/${PN}-2.1.27-doc_build_fix.patch"
+)
+
+pkg_setup() {
+       java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # Get rid of the -R switch (runpath_switch for Sun)
+       # >=gcc-4.6 errors out with unknown option
+       sed -i -e '/LIB_SQLITE.*-R/s/ -R[^"]*//' \
+               configure.ac || die
+
+       # Use plugindir for sasldir
+       sed -i '/^sasldir =/s:=.*:= $(plugindir):' \
+               "${S}"/plugins/Makefile.{am,in} || die "sed failed"
+
+       # #486740 #468556
+       sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' \
+               -e 's:AC_CONFIG_MACRO_DIR:AC_CONFIG_MACRO_DIRS:g' \
+               configure.ac || die
+
+       eautoreconf
+}
+
+src_configure() {
+       append-flags -fno-strict-aliasing
+       if [[ ${CHOST} == *-solaris* ]] ; then
+               # getpassphrase is defined in /usr/include/stdlib.h
+               append-cppflags -DHAVE_GETPASSPHRASE
+       else
+               # this horrendously breaks things on Solaris
+               append-cppflags -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -D_BSD_SOURCE -DLDAP_DEPRECATED
+       fi
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       # Java support.
+       multilib_is_native_abi && use java && export JAVAC="${JAVAC} ${JAVACFLAGS}"
+
+       local myeconfargs=(
+               --enable-login
+               --enable-ntlm
+               --enable-auth-sasldb
+               --disable-cmulocal
+               --disable-krb4
+               --disable-macos-framework
+               --enable-otp
+               --without-sqlite
+               --with-saslauthd="${EPREFIX}"/run/saslauthd
+               --with-pwcheck="${EPREFIX}"/run/saslauthd
+               --with-configdir="${EPREFIX}"/etc/sasl2
+               --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/sasl2
+               --with-dbpath="${EPREFIX}"/etc/sasl2/sasldb2
+               $(use_with ssl openssl)
+               $(use_with pam)
+               $(use_with openldap ldap)
+               $(use_enable ldapdb)
+               $(multilib_native_use_enable sample)
+               $(use_enable kerberos gssapi)
+               $(multilib_native_use_enable java)
+               $(multilib_native_use_with mysql mysql "${EPREFIX}"/usr)
+               $(multilib_native_use_with postgres pgsql "${EPREFIX}"/usr/$(get_libdir)/postgresql)
+               $(use_with sqlite sqlite3 "${EPREFIX}"/usr/$(get_libdir))
+               $(use_enable srp)
+               $(use_enable static-libs static)
+
+               # Add authdaemond support (bug #56523).
+               $(usex authdaemond --with-authdaemond="${EPREFIX}"/var/lib/courier/authdaemon/socket '')
+
+               # Fix for bug #59634.
+               $(usex ssl '' --without-des)
+
+               # Use /dev/urandom instead of /dev/random (bug #46038).
+               $(usex urandom --with-devrandom=/dev/urandom '')
+       )
+
+       if use sqlite || { multilib_is_native_abi && { use mysql || use postgres; }; } ; then
+               myeconfargs+=( --enable-sql )
+       else
+               myeconfargs+=( --disable-sql )
+       fi
+
+       # Default to GDBM if both 'gdbm' and 'berkdb' are present.
+       if use gdbm ; then
+               einfo "Building with GNU DB as database backend for your SASLdb"
+               myeconfargs+=( --with-dblib=gdbm )
+       elif use berkdb ; then
+               einfo "Building with BerkeleyDB as database backend for your SASLdb"
+               myeconfargs+=(
+                       --with-dblib=berkeley
+                       --with-bdb-incdir="$(db_includedir)"
+               )
+       else
+               einfo "Building without SASLdb support"
+               myeconfargs+=( --with-dblib=none )
+       fi
+
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+       emake
+
+       # Default location for java classes breaks OpenOffice (bug #60769).
+       # Thanks to axxo@gentoo.org for the solution.
+       if multilib_is_native_abi && use java ; then
+               jar -cvf ${PN}.jar -C java $(find java -name "*.class")
+       fi
+}
+
+multilib_src_install() {
+       default
+
+       if multilib_is_native_abi; then
+               if use sample ; then
+                       docinto sample
+                       dodoc "${S}"/sample/*.c
+                       exeinto /usr/share/doc/${P}/sample
+                       doexe sample/client sample/server
+               fi
+
+               # Default location for java classes breaks OpenOffice (bug #60769).
+               if use java; then
+                       java-pkg_dojar ${PN}.jar
+                       java-pkg_regso "${ED}/usr/$(get_libdir)/libjavasasl$(get_libname)"
+                       # hackish, don't wanna dig through makefile
+                       rm -rf "${ED}/usr/$(get_libdir)/java" || die
+                       docinto "java"
+                       dodoc "${S}/java/README" "${FILESDIR}/java.README.gentoo" "${S}"/java/doc/*
+                       dodir "/usr/share/doc/${PF}/java/Test"
+                       insinto "/usr/share/doc/${PF}/java/Test"
+                       doins "${S}"/java/Test/*.java
+               fi
+
+               dosbin saslauthd/testsaslauthd
+       fi
+}
+
+multilib_src_install_all() {
+       keepdir /etc/sasl2
+
+       dodoc AUTHORS ChangeLog doc/legacy/TODO
+       newdoc pwcheck/README README.pwcheck
+
+       newdoc docsrc/sasl/release-notes/$(ver_cut 1-2)/index.rst release-notes
+       edos2unix ${ED%/}/usr/share/doc/${PF}/release-notes
+
+       docinto html
+       dodoc doc/html/*.html
+
+       newpamd "${FILESDIR}/saslauthd.pam-include" saslauthd
+
+       newinitd "${FILESDIR}/pwcheck.rc6" pwcheck
+       systemd_dounit "${FILESDIR}/pwcheck.service"
+
+       newinitd "${FILESDIR}/saslauthd2.rc7" saslauthd
+       newconfd "${FILESDIR}/saslauthd-${SASLAUTHD_CONF_VER}.conf" saslauthd
+       systemd_dounit "${FILESDIR}/saslauthd.service"
+       systemd_dotmpfilesd "${FILESDIR}/${PN}.conf"
+
+       # The get_modname bit is important: do not remove the .la files on
+       # platforms where the lib isn't called .so for cyrus searches the .la to
+       # figure out what the name is supposed to be instead
+       if ! use static-libs && [[ $(get_modname) == .so ]] ; then
+               find "${ED}" -name "*.la" -delete || die
+       fi
+}
+
+pkg_postinst () {
+       # Generate an empty sasldb2 with correct permissions.
+       if ( use berkdb || use gdbm ) && [[ ! -f "${EROOT}/etc/sasl2/sasldb2" ]] ; then
+               einfo "Generating an empty sasldb2 with correct permissions ..."
+               echo "p" | "${EROOT}/usr/sbin/saslpasswd2" -f "${EROOT}/etc/sasl2/sasldb2" -p login \
+                       || die "Failed to generate sasldb2"
+               "${EROOT}/usr/sbin/saslpasswd2" -f "${EROOT}/etc/sasl2/sasldb2" -d login \
+                       || die "Failed to delete temp user"
+               chown root:mail "${EROOT}/etc/sasl2/sasldb2" \
+                       || die "Failed to chown ${EROOT}/etc/sasl2/sasldb2"
+               chmod 0640 "${EROOT}/etc/sasl2/sasldb2" \
+                       || die "Failed to chmod ${EROOT}/etc/sasl2/sasldb2"
+       fi
+
+       if use authdaemond ; then
+               elog "You need to add a user running a service using Courier's"
+               elog "authdaemon to the 'mail' group. For example, do:"
+               elog "  gpasswd -a postfix mail"
+               elog "to add the 'postfix' user to the 'mail' group."
+       fi
+
+       elog "pwcheck and saslauthd home directories have moved to:"
+       elog "  /run/saslauthd, using tmpfiles.d"
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-as_needed.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-as_needed.patch
new file mode 100644 (file)
index 0000000..7cd9e15
--- /dev/null
@@ -0,0 +1,25 @@
+Author: Matthias Klose <doko@ubuntu.com>
+Desription: Fix FTBFS, add $(SASL_DB_LIB) as dependency to libsasldb, and use
+it.
+--- cyrus-sasl-2.1.27/saslauthd/Makefile.am
++++ cyrus-sasl-2.1.27/saslauthd/Makefile.am
+@@ -25,7 +25,7 @@
+ saslauthd_DEPENDENCIES = saslauthd-main.o $(LTLIBOBJS_FULL)
+ saslauthd_LDADD       = @SASL_KRB_LIB@ \
+                 @GSSAPIBASE_LIBS@ @LIB_CRYPT@ @LIB_SIA@ \
+-                @LIB_SOCKET@ @SASL_DB_LIB@ @LIB_PAM@ @LDAP_LIBS@ $(LTLIBOBJS_FULL) $(CRYPTO_COMPAT_OBJS) $(LIBSASLDB_OBJS)
++                @LIB_SOCKET@ ../sasldb/libsasldb.la @LIB_PAM@ @LDAP_LIBS@ $(LTLIBOBJS_FULL) $(CRYPTO_COMPAT_OBJS) $(LIBSASLDB_OBJS)
+ testsaslauthd_SOURCES = testsaslauthd.c utils.c
+ testsaslauthd_LDADD = @LIB_SOCKET@
+--- cyrus-sasl-2.1.27/sasldb/Makefile.am
++++ cyrus-sasl-2.1.27/sasldb/Makefile.am
+@@ -54,6 +54,6 @@
+ libsasldb_la_SOURCES = allockey.c sasldb.h
+ EXTRA_libsasldb_la_SOURCES = $(extra_common_sources)
+-libsasldb_la_DEPENDENCIES = $(SASL_DB_BACKEND)
+-libsasldb_la_LIBADD = $(SASL_DB_BACKEND)
++libsasldb_la_DEPENDENCIES = $(SASL_DB_BACKEND) $(SASL_DB_LIB)
++libsasldb_la_LIBADD = $(SASL_DB_BACKEND) $(SASL_DB_LIB)
+ libsasldb_la_LDFLAGS = -no-undefined
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-autotools_fixes.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-autotools_fixes.patch
new file mode 100644 (file)
index 0000000..2ce971e
--- /dev/null
@@ -0,0 +1,31 @@
+--- cyrus-sasl-2.1.27/configure.ac
++++ cyrus-sasl-2.1.27/configure.ac
+@@ -44,6 +44,8 @@
+ AC_PREREQ(2.63)
++AC_CONFIG_MACRO_DIR([config])
++
+ dnl
+ dnl REMINDER: When changing the version number here, please also update
+ dnl the values in win32/include/config.h and include/sasl.h as well.
+--- cyrus-sasl-2.1.27/Makefile.am
++++ cyrus-sasl-2.1.27/Makefile.am
+@@ -44,6 +44,8 @@
+ #
+ ################################################################
++ACLOCAL_AMFLAGS = -I config
++
+ if SASLAUTHD
+ SAD = saslauthd
+ else
+--- cyrus-sasl-2.1.27/saslauthd/Makefile.am
++++ cyrus-sasl-2.1.27/saslauthd/Makefile.am
+@@ -1,4 +1,6 @@
+ AUTOMAKE_OPTIONS = 1.7
++ACLOCAL_AMFLAGS = -I ../config
++
+ sbin_PROGRAMS = saslauthd testsaslauthd
+ EXTRA_PROGRAMS  = saslcache
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-avoid_pic_overwrite.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-avoid_pic_overwrite.patch
new file mode 100644 (file)
index 0000000..c331039
--- /dev/null
@@ -0,0 +1,17 @@
+Author: Fabian Fagerholm <fabbe@debian.org>
+Description: This patch makes sure the non-PIC version of libsasldb.a, which
+is created out of non-PIC objects, is not going to overwrite the PIC version,
+which is created out of PIC objects. The PIC version is placed in .libs, and
+the non-PIC version in the current directory.  This ensures that both non-PIC
+and PIC versions are available in the correct locations.
+--- cyrus-sasl-2.1.27/lib/Makefile.am
++++ cyrus-sasl-2.1.27/lib/Makefile.am
+@@ -98,7 +98,7 @@
+ libsasl2.a: libsasl2.la $(SASL_STATIC_OBJS)
+       @echo adding static plugins and dependencies
+-      $(AR) cru .libs/$@ $(SASL_STATIC_OBJS)
++      $(AR) cru $@ $(SASL_STATIC_OBJS)
+       @for i in ./libsasl2.la ../common/libplugin_common.la ../sasldb/libsasldb.la ../plugins/lib*.la; do \
+       if test ! -f $$i; then continue; fi; . $$i; \
+       for j in $$dependency_libs foo; do \
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-doc_build_fix.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-doc_build_fix.patch
new file mode 100644 (file)
index 0000000..bdd02f7
--- /dev/null
@@ -0,0 +1,11 @@
+--- cyrus-sasl-2.1.27/docsrc/exts/sphinxlocal/writers/manpage.py
++++ cyrus-sasl-2.1.27/docsrc/exts/sphinxlocal/writers/manpage.py
+@@ -23,7 +23,7 @@
+ from sphinx import addnodes
+ from sphinx.locale import admonitionlabels, _
+ from sphinx.util.osutil import ustrftime
+-from sphinx.util.compat import docutils_version
++#from sphinx.util.compat import docutils_version
+ class CyrusManualPageWriter(ManualPageWriter):
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-gss_c_nt_hostbased_service.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.27-gss_c_nt_hostbased_service.patch
new file mode 100644 (file)
index 0000000..c585cb1
--- /dev/null
@@ -0,0 +1,16 @@
+Gentoo bug #389349
+--- cyrus-sasl-2.1.27/m4/sasl2.m4
++++ cyrus-sasl-2.1.27/m4/sasl2.m4
+@@ -220,7 +220,11 @@
+                  [AC_WARN([Cybersafe define not found])])
+   elif test "$ac_cv_header_gssapi_h" = "yes"; then
+-    AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi.h,
++    AC_EGREP_CPP(hostbased_service_gss_nt_yes, gssapi.h,
++                 [#include <gssapi.h>
++                  #ifdef GSS_C_NT_HOSTBASED_SERVICE
++                    hostbased_service_gss_nt_yes
++                  #endif],
+                     [AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE,,
+                                [Define if your GSSAPI implementation defines GSS_C_NT_HOSTBASED_SERVICE])])
+   elif test "$ac_cv_header_gssapi_gssapi_h"; then