dev-lang/spidermonkey: make sed use in icu.m4 compatible with sed-4.3
authorIan Stakenvicius <axs@gentoo.org>
Tue, 28 Feb 2017 18:46:54 +0000 (13:46 -0500)
committerIan Stakenvicius <axs@gentoo.org>
Tue, 28 Feb 2017 18:49:54 +0000 (13:49 -0500)
Bug: http://bugs.gentoo.org/611232
Bug: http://bugs.gentoo.org/604696

Package-Manager: portage-2.3.3

dev-lang/spidermonkey/files/mozilla_configure_regexp_esr38.patch [new file with mode: 0644]
dev-lang/spidermonkey/spidermonkey-38.2.1_rc0.ebuild

diff --git a/dev-lang/spidermonkey/files/mozilla_configure_regexp_esr38.patch b/dev-lang/spidermonkey/files/mozilla_configure_regexp_esr38.patch
new file mode 100644 (file)
index 0000000..488b02f
--- /dev/null
@@ -0,0 +1,32 @@
+From: Jory A. Pratt <anarchy@gentoo.org>
+
+Note: the first occurrence of :space: is [:space:] (with a single pair
+of []), where it should be [[:space:]] (with two pairs of []).
+
+This causes the sed command to fail (with the error message quoted in
+my original report), driving to failure the whole configure step.
+
+https://bugzilla.mozilla.org/show_bug.cgi?id=1329252
+
+diff --git a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
+--- a/build/autoconf/icu.m4
++++ b/build/autoconf/icu.m4
+@@ -68,17 +68,17 @@
+     icudir="$_topsrcdir/intl/icu/source"
+     if test ! -d "$icudir"; then
+         icudir="$_topsrcdir/../../intl/icu/source"
+         if test ! -d "$icudir"; then
+             AC_MSG_ERROR([Cannot find the ICU directory])
+         fi
+     fi
+-    version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
++    version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
+     if test x"$version" = x; then
+        AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
+     fi
+     MOZ_ICU_VERSION="$version"
+     if test -z "${JS_STANDALONE}" -a -n "${JS_SHARED_LIBRARY}${MOZ_NATIVE_ICU}"; then
+         MOZ_SHARED_ICU=1
+     fi
index ad154d68f81a5fbf0612e9240273d0e60806acd1..f03e6d13beedd6135ba86b70347e9ae07f03122c 100644 (file)
@@ -41,7 +41,8 @@ src_prepare() {
                "${FILESDIR}"/mozjs38-1269317.patch \
                "${FILESDIR}"/mozjs38-fix-tracelogger.patch \
                "${FILESDIR}"/mozjs38-copy-headers.patch \
-               "${FILESDIR}"/mozjs38-pkg-config-version.patch
+               "${FILESDIR}"/mozjs38-pkg-config-version.patch \
+               "${FILESDIR}"/mozilla_configure_regexp_esr38.patch
 
        eapply_user