Bumping to version 1.4.3
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>
Sat, 31 Mar 2007 18:33:38 +0000 (18:33 +0000)
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>
Sat, 31 Mar 2007 18:33:38 +0000 (18:33 +0000)
Package-Manager: portage-2.1.2.2

net-misc/libupnp/ChangeLog
net-misc/libupnp/files/digest-libupnp-1.4.3 [new file with mode: 0644]
net-misc/libupnp/libupnp-1.4.3.ebuild [new file with mode: 0644]

index 0bd5e199df8b0df8afc936b7a10fc02121867e88..642091a4ed731db12b5d67cd17091e9dcec00fa3 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-misc/libupnp
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/libupnp/ChangeLog,v 1.7 2007/03/06 08:38:23 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/libupnp/ChangeLog,v 1.8 2007/03/31 18:33:38 gurligebis Exp $
+
+  31 Mar 2007; Bjarke Istrup Pedersen <gurligebis@gentoo.org> -libupnp-1.4.2.ebuild,
+  +libupnp-1.4.3.ebuild:
+  Bumping to version 1.4.3
+
+*libupnp-1.4.3 (31 Mar 2007)
 
   06 Mar 2007; Markus Rothe <corsair@gentoo.org> libupnp-1.4.2.ebuild:
   Added ~ppc64; bug #168789
diff --git a/net-misc/libupnp/files/digest-libupnp-1.4.3 b/net-misc/libupnp/files/digest-libupnp-1.4.3
new file mode 100644 (file)
index 0000000..2930c39
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c87ba0840b78dfb3163c2d0d4e9cff9b libupnp-1.4.3.tar.bz2 1097956
+RMD160 885bffc54d9502465fb47632fafd43badffc9afd libupnp-1.4.3.tar.bz2 1097956
+SHA256 6c2149a23640ecd7368626d4428294dbe0fa571971c93909f4ff3fbaa74ba9f7 libupnp-1.4.3.tar.bz2 1097956
diff --git a/net-misc/libupnp/libupnp-1.4.3.ebuild b/net-misc/libupnp/libupnp-1.4.3.ebuild
new file mode 100644 (file)
index 0000000..4b17f0d
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/libupnp/libupnp-1.4.3.ebuild,v 1.1 2007/03/31 18:33:38 gurligebis Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pupnp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+RDEPEND="!net-misc/upnp"
+
+src_compile() {
+       # w/o docdir to avoid sandbox violations        
+       econf \
+               $(use_enable debug) \
+               --without-docdir \
+               || die "econf failed"
+       emake || die "emake failed"
+
+       # fix tests
+       chmod +x ixml/test/test_document.sh
+}
+
+src_install () {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dobin upnp/.libs/upnp_tv_{ctrlpt,device}
+       dodoc NEWS README ChangeLog
+       dohtml upnp/doc/*.pdf
+}
+