net-analyzer/alive: EAPI=7
authorJeroen Roovers <jer@gentoo.org>
Tue, 17 Dec 2019 09:36:42 +0000 (10:36 +0100)
committerJeroen Roovers <jer@gentoo.org>
Tue, 17 Dec 2019 09:38:15 +0000 (10:38 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/alive/alive-2.0.2-r1.ebuild [new file with mode: 0644]

diff --git a/net-analyzer/alive/alive-2.0.2-r1.ebuild b/net-analyzer/alive/alive-2.0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..9ee866d
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="a periodic ping program"
+HOMEPAGE="https://www.gnu.org/software/alive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+COMMON_DEPEND="
+       net-misc/iputils
+"
+DEPEND="
+       app-arch/xz-utils
+       ${COMMON_DEPEND}
+"
+RDEPEND="
+       dev-scheme/guile
+       ${COMMON_DEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${P}-ping-test.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}