x11-libs/fox: put tools behind use flag
authorJason A. Donenfeld <zx2c4@gentoo.org>
Sat, 28 Dec 2019 08:29:53 +0000 (09:29 +0100)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Sat, 28 Dec 2019 08:33:07 +0000 (09:33 +0100)
The earlier split packages paradigm is more maintenance burden than I'm
willing to take on, and doing it this way lets us more easily unify
things into one single ebuild. Besides, these are mostly example apps.

Updates: https://bugs.gentoo.org/703088
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
profiles/package.mask
x11-libs/fox/fox-1.7.67.ebuild
x11-libs/fox/metadata.xml

index 0e79c12ce61fa8913b956c4b4019de75cdc9d97d..5f6a0b3e06828571d29e068d61a4d121940b24ef 100644 (file)
@@ -160,7 +160,9 @@ app-editors/emacs-vcs
 app-benchmarks/spew
 
 # Jason A. Donenfeld <zx2c4@gentoo.org> (2019-12-16)
-# Simplify FOX packages. Nobody uses the demo apps or the "stable" branch.
+# Simplify FOX packages. Adie, calculator, pathfinder, and shutterbug
+# can now be found behind x11-libs/fox[tools], and reswrap is always
+# installed by it.
 # Removal in 30 days.  Bug #703088. Bug #703084.
 app-editors/adie
 dev-util/reswrap
index 564900ecba7d0fbfbccb9666eadffa58737232f6..aed93292abb6cea195abc59faa7d3f9cec91bf40 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.fox-toolkit.org/pub/${P}.tar.gz"
 LICENSE="LGPL-2.1"
 SLOT="1.7"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib debug doc profile"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib debug doc profile tools"
 
 RDEPEND="x11-libs/libXrandr
        x11-libs/libXcursor
@@ -37,10 +37,13 @@ src_prepare() {
        default
 
        sed -i '/#define REXDEBUG 1/d' lib/FXRex.cpp || die "Unable to remove spurious debug line."
-       local d
-       for d in windows adie calculator pathfinder shutterbug; do
-               sed -i -e "s:${d}::" Makefile.am || die "Unable to remove $d."
-       done
+       sed -i -e "s:windows::" Makefile.am
+       if ! use tools; then
+               local d
+               for d in adie calculator pathfinder shutterbug; do
+                       sed -i -e "s:${d}::" Makefile.am
+               done
+       fi
 
        # Respect system CXXFLAGS
        sed -i -e 's:CXXFLAGS=""::' configure.ac || die "Unable to force cxxflags."
index 915f00227065a9d4a499b0690f4c3d1015297cb5..a0084d6b4b7c7e01dd82471920684152de96d7e8 100644 (file)
@@ -5,4 +5,7 @@
                <email>zx2c4@gentoo.org</email>
                <name>Jason A. Donenfeld</name>
        </maintainer>
+       <use>
+               <flag name="tools">Install adie, calculator, shutterbug, and pathfinder apps.</flag>
+       </use>
 </pkgmetadata>