app-admin/consul-template: inherit go-build for GOPATH setting with get_golibdir_gopath
authorZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 05:26:35 +0000 (22:26 -0700)
committerZac Medico <zmedico@gentoo.org>
Mon, 10 Aug 2015 05:35:17 +0000 (22:35 -0700)
Package-Manager: portage-2.2.20

app-admin/consul-template/consul-template-0.9.0-r1.ebuild
app-admin/consul-template/consul-template-0.9.0.ebuild
app-admin/consul-template/consul-template-9999.ebuild

index fd646ee7809da5aad37f3b42245008cd4be09e6e..cbc1059efff734cda1158279ce4980ad0300d3df 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit systemd user
+inherit golang-base systemd user
 
 KEYWORDS="~amd64"
 DESCRIPTION="Generic template rendering and notifications with Consul"
@@ -68,7 +68,7 @@ unpack_go_packages() {
 
 src_unpack() {
        unpack_go_packages
-       export GOPATH=${WORKDIR}
+       export GOPATH=${WORKDIR}:$(get_golibdir_gopath)
 }
 
 src_prepare() {
index 0abadf7d7d2b02de7c67d45b6a54ac9525f380ad..80a3de8adbf5f042b59719eeb322eed553af2937 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit systemd user
+inherit golang-base systemd user
 
 KEYWORDS="~amd64"
 DESCRIPTION="Generic template rendering and notifications with Consul"
@@ -68,7 +68,7 @@ unpack_go_packages() {
 
 src_unpack() {
        unpack_go_packages
-       export GOPATH=${WORKDIR}
+       export GOPATH=${WORKDIR}:$(get_golibdir_gopath)
 }
 
 src_prepare() {
index 40307ab7352039823e3880c9118da7a6088c95f5..0dcf7f1b954150657df32ffedfe371a8d6dec6c9 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit git-r3 systemd user
+inherit git-r3 golang-base systemd user
 
 KEYWORDS=""
 DESCRIPTION="Generic template rendering and notifications with Consul"
@@ -32,7 +32,7 @@ pkg_setup() {
 }
 
 src_unpack() {
-       export GOPATH=${WORKDIR}
+       export GOPATH=${WORKDIR}:$(get_golibdir_gopath)
        git-r3_src_unpack
        go get -d -v ./... $(go list -f '{{range .TestImports}}{{.}} {{end}}' ./...) || die
 }