anacron: improve CFLAGS/CC handling
authorMike Frysinger <vapier@gentoo.org>
Mon, 10 Aug 2015 07:39:36 +0000 (03:39 -0400)
committerMike Frysinger <vapier@gentoo.org>
Mon, 10 Aug 2015 07:59:50 +0000 (03:59 -0400)
Rather than expand CFLAGS in the sed statement, pass it via the env later
on when running make.

Make sure we set up CC to a sane default.

sys-process/anacron/anacron-2.3-r3.ebuild

index aa35863c8a09d316cea4a95518547da1bd840e30..202cfdd6b88993aeec9bc1ae58c735fb811751d7 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI="5"
 
-inherit eutils
+inherit eutils toolchain-funcs
 
 DESCRIPTION="a periodic command scheduler"
 HOMEPAGE="http://anacron.sourceforge.net/"
@@ -21,7 +21,13 @@ RDEPEND="${RDEPEND}
 
 src_prepare() {
        epatch "${FILESDIR}"/${P}-compile-fix-from-debian.patch
-       sed -i "s:^CFLAGS =:CFLAGS = $CFLAGS:" Makefile
+       sed -i \
+               -e '/^CFLAGS/{s:=:+=:;s:-O2::}' \
+               Makefile || die
+}
+
+src_configure() {
+       tc-export CC
 }
 
 src_install() {