net-proxy/sshuttle: version bump to 0.78.1
authorTim Harder <radhermit@gentoo.org>
Wed, 10 Aug 2016 03:00:55 +0000 (23:00 -0400)
committerTim Harder <radhermit@gentoo.org>
Wed, 10 Aug 2016 03:02:10 +0000 (23:02 -0400)
net-proxy/sshuttle/Manifest
net-proxy/sshuttle/sshuttle-0.78.1.ebuild [new file with mode: 0644]

index bb119f64130b2b8520db7c70cedc1b422190e50a..a4b01bdf2c8d7b983b8965fcba8f523101876040 100644 (file)
@@ -1 +1,2 @@
 DIST sshuttle-0.78.0.tar.gz 63391 SHA256 6bd80d48f73eb04d4449a8aa636081704107cfdef05980b3b02166ff44e419a2 SHA512 e4ecb09e79905c1be6d3d7935863231c54bd68144fbb1ca38af29d5efb35c42261db4319368d5c83474ed9714859b04012c9ad4108a77d283a0a041356f90cbd WHIRLPOOL 9f7c0ea7be81b4605ee4e9c14be1bc309fc273cc367be348a64f04569e5505888a12350e0ac07415edc541539dfdc3c3a5c6ac90421189dd6c6567ccc2131b37
+DIST sshuttle-0.78.1.tar.gz 67173 SHA256 03a71648ce476de06a075bd9a972492d494b414ae51304bf535b80ff22be2d3c SHA512 506b01f20d152e97a41c93299f47d6bba4d7f9fda11e066aca3d79426be68790ff30a3a081ea05ca538aba921ed69e711b672fcfd9084aba6bdae6498beb7e8d WHIRLPOOL d356bf17ba5f6f01351dc316745af3fd07237160340f675e1ecef52d73cb15caf4c5eee65d1ed56ea4008081623362688957f268da30d487d5aa6be02632ddda
diff --git a/net-proxy/sshuttle/sshuttle-0.78.1.ebuild b/net-proxy/sshuttle/sshuttle-0.78.1.ebuild
new file mode 100644 (file)
index 0000000..cb49965
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5} )
+
+inherit linux-info distutils-r1
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.python.org/pypi/sshuttle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       net-firewall/iptables
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~NF_NAT"
+
+python_prepare_all() {
+       # don't run tests via setup.py pytest
+       sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       py.test || die "Tests fail under ${EPYTHON}"
+}