media-gfx/eog-plugins: run python_setup for non-binary pkg_setup
authorGilles Dartiguelongue <eva@gentoo.org>
Sun, 23 Aug 2015 16:09:08 +0000 (18:09 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Sun, 23 Aug 2015 16:09:50 +0000 (18:09 +0200)
Thanks to hasufell for spotting this issue.

Package-Manager: portage-2.2.20.1

media-gfx/eog-plugins/eog-plugins-3.14.2.ebuild
media-gfx/eog-plugins/eog-plugins-3.16.0.ebuild
media-gfx/eog-plugins/eog-plugins-3.16.1.ebuild

index 04dcd0eea3ec376b4e1700cf43edf55fcfb11cba..1c379c7dd4387baaa5f52ab7b5e4d9022ab52159 100644 (file)
@@ -50,7 +50,7 @@ DEPEND="${RDEPEND}
 "
 
 pkg_setup() {
-       use python && [[ ${MERGE_TYPE} == binary ]] && python_setup
+       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
 }
 
 src_configure() {
index 714d7fdc9dd7cc897618a0d605d30f1569e6ae43..5d2c6565505ec7cf74c6be1744ced2d3a4c1e4d9 100644 (file)
@@ -50,7 +50,7 @@ DEPEND="${RDEPEND}
 "
 
 pkg_setup() {
-       use python && [[ ${MERGE_TYPE} == binary ]] && python_setup
+       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
 }
 
 src_configure() {
index 714d7fdc9dd7cc897618a0d605d30f1569e6ae43..5d2c6565505ec7cf74c6be1744ced2d3a4c1e4d9 100644 (file)
@@ -50,7 +50,7 @@ DEPEND="${RDEPEND}
 "
 
 pkg_setup() {
-       use python && [[ ${MERGE_TYPE} == binary ]] && python_setup
+       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
 }
 
 src_configure() {