dev-python/python-cjson: version bump to 1.2.1
authorTim Harder <radhermit@gentoo.org>
Sun, 29 Apr 2018 04:29:56 +0000 (00:29 -0400)
committerTim Harder <radhermit@gentoo.org>
Sun, 29 Apr 2018 04:29:56 +0000 (00:29 -0400)
dev-python/python-cjson/Manifest
dev-python/python-cjson/python-cjson-1.2.1.ebuild [new file with mode: 0644]

index 8eb40c35d97f2dc97ba6852aa6babb1702b4bc4c..4e7e04c4fa5093d2c7bda8410c81d6d38e41d0ac 100644 (file)
@@ -1 +1,2 @@
 DIST python-cjson-1.1.0.tar.gz 12298 BLAKE2B 80d189c5884ba4187d16da6d18279e568519c84d83bec343bfe14a8408ae5a5ce9bd6a578381cf171c61b8aad2887bf0b7af2de2dc11a7cc065f4573ce584aa1 SHA512 039e5f724c3a49d0043f788b0634c4191a6ae5abaa012d8491622e5a9ac22ecc5a342a0243f70b0ac02c8640243aaf8b0cf20a0ab12ee4866d9af966d73c1706
+DIST python-cjson-1.2.1.tar.gz 12575 BLAKE2B 2f1ee29490ab8cbb342af76758cb418763a007a00de73f96215793e39924e81deefc1b1ef65350a99a38b3df974129a40a9570ea27e0cd25d384aad5c513a5a1 SHA512 dd998d1a77c4ac2f48316a66bb10741860a1ed7b8f54431bd72f949a4070284fa5040ed51c3030f7ad9fed4d76e12112206d32acf204800010c8b79b1665d684
diff --git a/dev-python/python-cjson/python-cjson-1.2.1.ebuild b/dev-python/python-cjson/python-cjson-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..3e69886
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/AGProjects/python-cjson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+       "${PYTHON}" jsontest.py || die
+}