media-libs/imlib2: switch amd64 asm flag to sse2 from mmx #218382
authorMike Frysinger <vapier@gentoo.org>
Fri, 14 Aug 2015 06:35:01 +0000 (02:35 -0400)
committerMike Frysinger <vapier@gentoo.org>
Fri, 14 Aug 2015 06:36:04 +0000 (02:36 -0400)
The actual assembly code is written using SSE2, so this reflects the
source better.  It also has the nice feature of side-stepping the mmx
mask in the amd64 profile so people can enable it now.

media-libs/imlib2/imlib2-9999.ebuild

index 3d0fb2ef858f752df966d7ed149d754e39a53f87..9ec411dac7d2bc3bb9b0ca6c99cac9b31ff10952 100644 (file)
@@ -16,7 +16,7 @@ inherit enlightenment toolchain-funcs multilib-minimal
 DESCRIPTION="Version 2 of an advanced replacement library for libraries like libXpm"
 HOMEPAGE="http://www.enlightenment.org/"
 
-IUSE="bzip2 gif jpeg cpu_flags_x86_mmx mp3 png static-libs tiff X zlib"
+IUSE="bzip2 gif jpeg cpu_flags_x86_mmx cpu_flags_x86_sse2 mp3 png static-libs tiff X zlib"
 
 RDEPEND="=media-libs/freetype-2*[${MULTILIB_USEDEP}]
        bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
@@ -38,9 +38,9 @@ DEPEND="${RDEPEND}
        )"
 
 multilib_src_configure() {
-       # imlib2 has diff configure options for x86/amd64 mmx
+       # imlib2 has diff configure options for x86/amd64 assembly
        if [[ $(tc-arch) == amd64 ]]; then
-               E_ECONF+=( $(use_enable cpu_flags_x86_mmx amd64) --disable-mmx )
+               E_ECONF+=( $(use_enable cpu_flags_x86_sse2 amd64) --disable-mmx )
        else
                E_ECONF+=( --disable-amd64 $(use_enable cpu_flags_x86_mmx mmx) )
        fi