dev-util/boost-build: Bump to version 1.72.0
authorDavid Seifert <soap@gentoo.org>
Sun, 15 Dec 2019 14:20:11 +0000 (15:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 15 Dec 2019 14:20:11 +0000 (15:20 +0100)
* Completely remove USE="python" support. Noone
  has ever used this scripts, and to date they are
  still not python 3 compatible.

Closes: https://bugs.gentoo.org/702396
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/boost-build/Manifest
dev-util/boost-build/boost-build-1.72.0.ebuild [new file with mode: 0644]

index 1d613291002830714d6096278165b56e9c6221f6..2fab5165b1ba3173ff13fae23bf4796fe66b8f63 100644 (file)
@@ -1 +1,2 @@
 DIST boost_1_71_0.tar.bz2 100124647 BLAKE2B edf5a03d5a5a63ef5826ef3c19a5ee862a43eb93e8e3d76f8a0d1f2c23122f5a0535e045058110574cd19092f3199c28ab9dae53f9db05ffe8c0b0b8cdbe27a9 SHA512 b7937d50c4512cf13cadd0ca829de36cf2cbc6fb788f45b1d4565ad0753e2b206c545125a5862016c2f16016f2e4a6b687928963b466fff17c3e0a4437142c20
+DIST boost_1_72_0.tar.bz2 106907358 BLAKE2B ab270a0e3cb24da687d86785e2d2e6d7731b4dbc07bd839eadb642dfa5a428ad584acb1f3529661a8de9a986008ff3427491041059ea2b742348d02e00761cd8 SHA512 63bbd1743e7c904b2e69fdc2eafd1c2a8a30fd70d960dcd366059d0100f000cb605d56cbd9397bb18421631f1c9552a772c434d0f0caddbe56302273f51fd1f6
diff --git a/dev-util/boost-build/boost-build-1.72.0.ebuild b/dev-util/boost-build/boost-build-1.72.0.ebuild
new file mode 100644 (file)
index 0000000..00a3c7d
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic prefix toolchain-funcs
+
+MY_PV="$(ver_rs 1- _)"
+
+DESCRIPTION="A system for large project software construction, simple to use and powerful"
+HOMEPAGE="https://boostorg.github.io/build/"
+SRC_URI="https://dl.bintray.com/boostorg/release/${PV}/source/boost_${MY_PV}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+RESTRICT="test"
+
+S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
+       "${FILESDIR}"/${PN}-1.71.0-darwin-gentoo-toolchain.patch
+       "${FILESDIR}"/${PN}-1.71.0-add-none-feature-options.patch
+       "${FILESDIR}"/${PN}-1.71.0-respect-c_ld-flags.patch
+       "${FILESDIR}"/${PN}-1.71.0-no-implicit-march-flags.patch
+)
+
+src_unpack() {
+       tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
+}
+
+src_prepare() {
+       default
+
+       pushd .. >/dev/null || die
+       eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
+       popd >/dev/null || die
+}
+
+src_configure() {
+       hprefixify engine/Jambase
+       tc-export CXX
+}
+
+src_compile() {
+       cd engine || die
+       ./build.sh cxx -d+2 --without-python || die "building bjam failed"
+}
+
+src_test() {
+       # Forget tests, bjam is a lost cause
+       :
+}
+
+src_install() {
+       dobin engine/{bjam,b2}
+
+       insinto /usr/share/boost-build
+       doins -r "${FILESDIR}/site-config.jam" \
+               ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
+               build kernel options tools util
+
+       find "${ED}"/usr/share/boost-build -iname '*.py' -delete || die
+
+       dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
+
+       if use examples; then
+               docinto examples
+               dodoc -r ../example/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}