media-libs/libsndfile: python3_8 support
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 15:30:10 +0000 (17:30 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 15:56:38 +0000 (17:56 +0200)
Tests passed.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/libsndfile/libsndfile-1.0.29_pre2_p20191024.ebuild
media-libs/libsndfile/libsndfile-9999.ebuild

index cb2856695fd050bdfa337435ebee75a405ea529c..f9fdbe8931b3de9dd64eb1aeb2f21dd4ada432fe 100644 (file)
@@ -3,20 +3,21 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
 
 inherit autotools python-any-r1 multilib-minimal
 
 MY_COMMIT="97a361afc24202b16489d8c06910277c06b18b53"
 
-SRC_URI="https://github.com/erikd/libsndfile/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
 DESCRIPTION="C library for reading and writing files containing sampled sound"
 HOMEPAGE="http://www.mega-nerd.com/libsndfile"
+SRC_URI="https://github.com/erikd/libsndfile/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="LGPL-2.1"
 SLOT="0"
 IUSE="alsa minimal sqlite static-libs test"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -33,7 +34,7 @@ BDEPEND="
        virtual/pkgconfig
        ${PYTHON_DEPS}
        sys-devel/autogen
-       "
+"
 
 S="${WORKDIR}/${PN}-${MY_COMMIT}"
 
index 3ef48c7a3287283edaa378065c580484598ed9eb..b5b4cddaa034f4f3b74be97764c8143e0e7c301b 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{3_6,3_7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
 
 if [[ ${PV} == *9999 ]]; then
        inherit autotools git-r3