media-plugins/vdr-lcdproc: compile fix for media-video/vdr-2.4
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Wed, 25 Dec 2019 22:11:26 +0000 (23:11 +0100)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Wed, 25 Dec 2019 22:11:26 +0000 (23:11 +0100)
needs media-video/vdr-2.4
invalid suffix on literal; C++11 issues fixed
moved to eapi 7

Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
media-plugins/vdr-lcdproc/files/vdr-2.4_lcdproc-0.0.10.9.patch [new file with mode: 0644]
media-plugins/vdr-lcdproc/vdr-lcdproc-0.0.10.9-r1.ebuild [new file with mode: 0644]
media-plugins/vdr-lcdproc/vdr-lcdproc-0.0.10.9.ebuild

diff --git a/media-plugins/vdr-lcdproc/files/vdr-2.4_lcdproc-0.0.10.9.patch b/media-plugins/vdr-lcdproc/files/vdr-2.4_lcdproc-0.0.10.9.patch
new file mode 100644 (file)
index 0000000..0d2bbe4
--- /dev/null
@@ -0,0 +1,45 @@
+compilefix for vdr-2.4
+Suggested-by: MatthiasK @ vdr-portal.de
+
+fixed invalid suffix on literal; C++11 space issues
+
+Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> ( 25 Dec 2019 )
+diff -Naur lcdproc-0.0.10-jw9.orig/lcd.c lcdproc-0.0.10-jw9/lcd.c
+--- lcdproc-0.0.10-jw9.orig/lcd.c      2019-12-25 22:53:55.187492713 +0100
++++ lcdproc-0.0.10-jw9/lcd.c   2019-12-25 22:54:33.075492713 +0100
+@@ -808,7 +808,7 @@
+         cLcd::Write(LcdSetup.ShowTime?1:4," Welcome  to  V D R\0");
+         cLcd::Write(LcdSetup.ShowTime?2:3,"--------------------\0");
+         cLcd::Write(LcdSetup.ShowTime?3:1,"Video Disk Recorder\0");
+-        cLcd::Write(LcdSetup.ShowTime?4:2,"Version: "VDRVERSION"\0");
++        cLcd::Write(LcdSetup.ShowTime?4:2,"Version: " VDRVERSION "\0");
+         // Output init
+         if (LcdSetup.OutputNumber > 0){
+@@ -850,11 +850,15 @@
+                 }
+                 if ( time(NULL) > nextLcdUpdate ) {
+-                        cChannel *channel = Channels.GetByNumber(primaryDvbApi->CurrentChannel());
++//                      cChannel *channel = Channels.GetByNumber(primaryDvbApi->CurrentChannel());
++                        LOCK_CHANNELS_READ;
++                        const cChannel *channel = Channels->GetByNumber(primaryDvbApi->CurrentChannel());
+                         const cEvent *Present = NULL;
+-                        cSchedulesLock schedulesLock;
++/*                      cSchedulesLock schedulesLock;
+                         const cSchedules *Schedules = cSchedules::Schedules(schedulesLock);
+                         if (Schedules) {
++                                const cSchedule *Schedule = Schedules->GetSchedule(channel->GetChannelID()); */
++                                LOCK_SCHEDULES_READ;
+                                 const cSchedule *Schedule = Schedules->GetSchedule(channel->GetChannelID());
+                                 if (Schedule) {
+                                         const char *PresentTitle, *PresentSubtitle;
+@@ -873,7 +877,7 @@
+                                                 rtcycle = 10; // RT
+                                                 lcrCycle = 10; // LCR
+                                 }
+-                        }
++//                      }
+                         if ( nextLcdUpdate <= time(NULL) )
+                                 nextLcdUpdate=(time(NULL)/60)*60+60;
+                 }
diff --git a/media-plugins/vdr-lcdproc/vdr-lcdproc-0.0.10.9-r1.ebuild b/media-plugins/vdr-lcdproc/vdr-lcdproc-0.0.10.9-r1.ebuild
new file mode 100644 (file)
index 0000000..fa5d74a
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+VERSION="932" # every bump, new version
+
+MY_P=${PN}-$(ver_rs 3 -jw ${PV})
+
+DESCRIPTION="VDR plugin: use LCD device for additional output"
+HOMEPAGE="https://projects.vdr-developer.org/projects/plg-lcdproc"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${MY_P}.tgz -> ${P}.tgz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=app-misc/lcdproc-0.4.3
+               >=media-video/vdr-2.4"
+
+PATCHES=( "${FILESDIR}/vdr-2.4_lcdproc-0.0.10.9.patch" )
+
+S=${WORKDIR}/${MY_P#vdr-}
index 207b8e2c1334c3a9116affd5d680f370daea54a3..966c08c4fec99038e4c155e59ed23dda0b2c669a 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit vdr-plugin-2 versionator
+inherit vdr-plugin-2
 
 VERSION="932" # every bump, new version
 
-MY_P=${PN}-$(replace_version_separator 3 -jw ${PV})
+MY_P=${PN}-$(ver_rs 3 -jw ${PV})
 
 DESCRIPTION="VDR plugin: use LCD device for additional output"
 HOMEPAGE="https://projects.vdr-developer.org/projects/plg-lcdproc"