media-fonts/cheapskatefonts: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 16:44:53 +0000 (18:44 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 16:44:53 +0000 (18:44 +0200)
Bug: https://bugs.gentoo.org/697302
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-fonts/cheapskatefonts/cheapskatefonts-1.0.ebuild

index 28ce35dbaa9a56d3f12a7d18542f4c590a56a658..c90ad093205b74bcff6a6d55935bbfc708d28e24 100644 (file)
@@ -1,13 +1,14 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit font
 
 DESCRIPTION="Dustismo's decorative font collection"
 HOMEPAGE="http://www.dustismo.com/site/fonts.html"
-SRC_URI="http://www.dustismo.com/fonts/Domestic_Manners.zip
+SRC_URI="
+       http://www.dustismo.com/fonts/Domestic_Manners.zip
        http://www.dustismo.com/fonts/PenguinAttack.zip
        http://www.dustismo.com/fonts/Dustismo.zip
        http://www.dustismo.com/fonts/El_Abogado_Loco.zip
@@ -23,19 +24,10 @@ SRC_URI="http://www.dustismo.com/fonts/Domestic_Manners.zip
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ~ppc s390 sh sparc x86"
-IUSE=""
 
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
 
-S=${WORKDIR}
-FONT_S=${S}
-FONT_SUFFIX="ttf"
+S="${WORKDIR}"
 
-src_unpack() {
-       for zip in ${A} ; do
-               echo ">>> Unpacking ${zip} to ${WORKDIR}"
-               unzip -n ${DISTDIR}/${zip} > /dev/null \
-                       || die "failed to unpack ${zip}"
-       done
-}
+FONT_S="${S}"
+FONT_SUFFIX="ttf"