dev-haskell/network-data: avoid using underscores in IUSE
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 26 Sep 2019 08:19:06 +0000 (09:19 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 26 Sep 2019 08:19:06 +0000 (09:19 +0100)
Closes: https://bugs.gentoo.org/695036
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/network-data/metadata.xml
dev-haskell/network-data/network-data-0.5.3.ebuild

index e4533ee51f10fa85858f5aa25f2ab87b2de38f05..5738ce3e28f249b6db7908065b8057efbaaa1ae7 100644 (file)
@@ -6,7 +6,7 @@
                <name>Gentoo Haskell</name>
        </maintainer>
        <use>
-               <flag name="small_base">Build the split-up base package.</flag>
+               <flag name="small-base">Build the split-up base package.</flag>
        </use>
        <longdescription>
                This library includes definitions for common headers such as
index 88fb2d22239649c0110ea65d872e2bb54fd32136..97806aa0ea2d66f2932f4b31a13376bec2485d9b 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-# ebuild generated by hackport 0.4.5.9999
+# ebuild generated by hackport 0.6.9999
 
 CABAL_FEATURES="lib profile haddock hoogle hscolour"
 inherit haskell-cabal
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~x86"
-IUSE="+small_base"
+IUSE="+small-base"
 
 # dev-haskell/prettyclass is not required for ghc 7.10.1, just adding
 # it for backwards compatibility with <ghc 7.10.1
@@ -37,5 +37,5 @@ src_prepare() {
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag small_base small_base)
+               $(cabal_flag small-base small_base)
 }