dev-python/intreehooks: New package
authorPatrick McLean <chutzpah@gentoo.org>
Sat, 7 Dec 2019 20:06:09 +0000 (12:06 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Sat, 7 Dec 2019 21:55:29 +0000 (13:55 -0800)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/intreehooks/Manifest [new file with mode: 0644]
dev-python/intreehooks/intreehooks-1.0.ebuild [new file with mode: 0644]
dev-python/intreehooks/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/intreehooks/Manifest b/dev-python/intreehooks/Manifest
new file mode 100644 (file)
index 0000000..cde19e0
--- /dev/null
@@ -0,0 +1 @@
+DIST intreehooks-1.0.tar.gz 2701 BLAKE2B 2c82bae05cf3fc3bde13e8dd2ffb9d1ef79edc6711b5038f6f9b3dddd863492be24a425bf848c9868ecf730f813243fb5fa50ebfad52b44341be18e72727f195 SHA512 5a020dd6bd7994eca5f476618f57e2d86567756fae74f6fa50b6fbc96accfe8db910f3175bafa3ce85f37b05edc05ca1042dcec78407a241cfaffc0a0e997f4e
diff --git a/dev-python/intreehooks/intreehooks-1.0.ebuild b/dev-python/intreehooks/intreehooks-1.0.ebuild
new file mode 100644 (file)
index 0000000..a2471a8
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+inherit distutils-r1
+
+DESCRIPTION="Load a PEP 517 backend from inside the source tree"
+HOMEPAGE="https://pypi.org/project/intreehooks https://github.com/takluyver/intreehooks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+       dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       # replace pytoml with toml
+       sed -e 's:pytoml:toml:' \
+               -i setup.py intreehooks.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       local -a DOCS=( README.rst )
+       use examples && dodoc -r examples
+
+       distutils-r1_python_install_all
+}
diff --git a/dev-python/intreehooks/metadata.xml b/dev-python/intreehooks/metadata.xml
new file mode 100644 (file)
index 0000000..34d6356
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">intreehooks</remote-id>
+    <remote-id type="github">takluyver/intreehooks</remote-id>
+  </upstream>
+</pkgmetadata>