dev-libs/boost: Add python 3.8 back
authorDavid Seifert <soap@gentoo.org>
Thu, 2 Apr 2020 08:40:33 +0000 (10:40 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 2 Apr 2020 08:40:33 +0000 (10:40 +0200)
Closes: https://github.com/gentoo/gentoo/pull/15184
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/boost/boost-1.72.0-r1.ebuild
profiles/base/package.use.stable.mask

index 0b76e3fd937c41d864d5a2b9b1d1e2069096a5b7..278be9b830d7c0c454db0bf1346b49e50d152667 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
 
 inherit flag-o-matic multiprocessing python-r1 toolchain-funcs multilib-minimal
 
@@ -39,7 +39,7 @@ RDEPEND="
        mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP},cxx,threads] )
        python? (
                ${PYTHON_DEPS}
-               numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+               numpy? ( $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' -3) )
        )
        zlib? ( sys-libs/zlib:=[${MULTILIB_USEDEP}] )
        zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )"
index 03f6afbc88e0ee8405b8ae685eb8642f122002e2..21debf861c6d11dfc6d5ab0e4c74978ef79e8cc4 100644 (file)
@@ -4,6 +4,11 @@
 # This file requires eapi 5 or later. New entries go on top.
 # Please use the same syntax as in package.use.mask
 
+# David Seifert <soap@gentoo.org> (2020-03-31)
+# Numpy support in Boost.Python is brittle and shouldn't be enabled
+# on stable systems or force a stable upgrade.
+dev-libs/boost numpy
+
 # Brian Evans <grknight@gentoo.org> (2020-02-27)
 # Two packages are delayed during stable of PHP 7.4
 # arm, arm64 and hppa necessary to not disruput consistency