dev-haskell/http-streams: new package, a depend of snap-server-1
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:14:44 +0000 (21:14 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:57:03 +0000 (21:57 +0000)
An HTTP client using io-streams

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/http-streams/Manifest [new file with mode: 0644]
dev-haskell/http-streams/http-streams-0.8.4.0.ebuild [new file with mode: 0644]
dev-haskell/http-streams/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/http-streams/Manifest b/dev-haskell/http-streams/Manifest
new file mode 100644 (file)
index 0000000..d84e819
--- /dev/null
@@ -0,0 +1 @@
+DIST http-streams-0.8.4.0.tar.gz 35330 SHA256 d8778352ca3d87b7ea6839d9c26e20d89792e723a6b63e399d19e7811aaf4793 SHA512 763287042b37eca43941369dd2b7a7693f545ef37d87bdadb0b5ee686648bc0c3e7d2a8edee37648bb61ebc1dfefb029ca3ce22a44519a16775eab98de0b0a1a WHIRLPOOL 6d4fb38481b91eee2bb839485a5e9b6f09b08f94b8fff3a909a5e66d9bdd04a92fd5d711e9ff255e57d56aa379756d071d90e7ba1206e6b0f07f3f7ab7db7b29
diff --git a/dev-haskell/http-streams/http-streams-0.8.4.0.ebuild b/dev-haskell/http-streams/http-streams-0.8.4.0.ebuild
new file mode 100644 (file)
index 0000000..f0581b2
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client using io-streams"
+HOMEPAGE="http://research.operationaldynamics.com/projects/http-streams/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RESTRICT=test # cyclic dep: http-streams[test]->snap-server->http-streams
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+       dev-haskell/attoparsec:=[profile?]
+       dev-haskell/base64-bytestring:=[profile?]
+       >=dev-haskell/blaze-builder-0.4:=[profile?]
+       dev-haskell/case-insensitive:=[profile?]
+       >=dev-haskell/hsopenssl-0.10.3.5:=[profile?]
+       >=dev-haskell/http-common-0.8.2:=[profile?]
+       >=dev-haskell/io-streams-1.3:=[profile?] <dev-haskell/io-streams-1.4:=[profile?]
+       dev-haskell/mtl:=[profile?]
+       >=dev-haskell/openssl-streams-1.1:=[profile?] <dev-haskell/openssl-streams-1.4:=[profile?]
+       dev-haskell/text:=[profile?]
+       dev-haskell/unordered-containers:=[profile?]
+       >=dev-lang/ghc-7.8.2:=
+       network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+                       >=dev-haskell/network-uri-2.6:=[profile?] )
+       !network-uri? ( <dev-haskell/network-2.6:=[profile?]
+                       <dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.18.1.3
+       test? ( dev-haskell/aeson-pretty
+               dev-haskell/hspec
+               dev-haskell/hspec-expectations
+               dev-haskell/hunit
+               dev-haskell/lifted-base
+               >=dev-haskell/snap-core-1.0 <dev-haskell/snap-core-1.1
+               >=dev-haskell/snap-server-1.0 <dev-haskell/snap-server-1.1
+               >=dev-haskell/system-fileio-0.3.10 <dev-haskell/system-fileio-0.4
+               >=dev-haskell/system-filepath-0.4.1 <dev-haskell/system-filepath-0.5
+               !network-uri? ( >=dev-haskell/network-2.6
+                               >=dev-haskell/network-uri-2.6 ) )
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               $(cabal_flag network-uri network-uri)
+}
diff --git a/dev-haskell/http-streams/metadata.xml b/dev-haskell/http-streams/metadata.xml
new file mode 100644 (file)
index 0000000..3e1a4d2
--- /dev/null
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               /Overview/
+               
+               An HTTP client, using the Snap Framework's 'io-streams' library to
+               hande the streaming IO. The API is optimized for ease of use for the
+               rather common case of code needing to query web services and deal with
+               the result.
+               
+               The library is exported in a single module; see "Network.Http.Client"
+               for full documentation.
+       </longdescription>
+       <use>
+               <flag name="network-uri">Get Network.URI from the network-uri package.</flag>
+       </use>
+</pkgmetadata>