app-benchmarks/bonnie: [QA] Minor touchups
authorDavid Seifert <soap@gentoo.org>
Thu, 28 Dec 2017 12:45:46 +0000 (13:45 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 28 Dec 2017 12:49:47 +0000 (13:49 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-benchmarks/bonnie/bonnie-2.0.6-r2.ebuild
app-benchmarks/bonnie/files/Makefile.patch

index c9fdf5a2ddb6e0a3f78e3f5ae2e541ee66875022..65ce1c40e0e8925df635b7bca6adf520efbcc1af 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="Performance Test of Filesystem I/O using standard C library calls"
 HOMEPAGE="http://www.textuality.com/bonnie/"
@@ -16,12 +16,14 @@ IUSE=""
 
 S=${WORKDIR}
 
-PATCHES=( "${FILESDIR}/bonnie_man.patch"
-         "${FILESDIR}/Makefile.patch"
-         "${FILESDIR}/${P}-includes.patch" )
+PATCHES=(
+       "${FILESDIR}"/bonnie_man.patch
+       "${FILESDIR}"/Makefile.patch
+       "${FILESDIR}"/${P}-includes.patch
+)
 
-src_compile() {
-       emake CC=$(tc-getCC) SYSFLAGS="${CFLAGS}"
+src_configure() {
+       tc-export CC
 }
 
 src_install() {
index c4367087b8b511282700ed9d7bc2a89736862f8b..d803bd077ced2077320de46341a53bdbf3572bee 100644 (file)
@@ -1,9 +1,8 @@
---- a/Makefile 1996-08-29 03:45:37.000000000 +0200
-+++ b/Makefile 2011-08-25 16:07:10.757629898 +0200
-@@ -1,11 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,9 @@
 -CFLAGS = -O $(SYSFLAGS)
-+CFLAGS = $(SYSFLAGS)
+-
  bsd:  
        @echo 'Options are "make bsd" and "make SysV" - the default is "bsd".'
        @echo 'If you get messages about missing functions, try "make SysV."'