Added as-needed patch, bug #155462 thanks to drizzt. Added 'test' USE-flag to track...
authorTiziano Müller <dev-zero@gentoo.org>
Sat, 18 Nov 2006 10:36:47 +0000 (10:36 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Sat, 18 Nov 2006 10:36:47 +0000 (10:36 +0000)
Package-Manager: portage-2.1.2_rc1-r5

dev-cpp/libebt/ChangeLog
dev-cpp/libebt/files/digest-libebt-1.3.0
dev-cpp/libebt/files/libebt-1.3.0-as-needed.patch [new file with mode: 0644]
dev-cpp/libebt/libebt-1.3.0.ebuild

index ccf280fa1e888ae21d39d677ea80d7c2ef1c297f..79f347da581b0992dd964543964091c3dd0b1a65 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-cpp/libebt
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/ChangeLog,v 1.16 2006/01/26 13:15:49 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/ChangeLog,v 1.17 2006/11/18 10:36:47 dev-zero Exp $
+
+  18 Nov 2006; Tiziano Müller <dev-zero@gentoo.org>
+  +files/libebt-1.3.0-as-needed.patch, -libebt-1.2.1.ebuild,
+  -libebt-1.2.2.ebuild, libebt-1.3.0.ebuild:
+  Added as-needed patch, bug #155462 thanks to drizzt. Added 'test' USE-flag
+  to track boost-dependency for testing. Dropped old versions.
 
 *libebt-1.3.0 (26 Jan 2006)
 
index d822b6a4acd1b0a0a8e524afa8a2b51c0d07d9f4..129f043cc1068d3d9d281fa82fb685eb666ffc66 100644 (file)
@@ -1 +1,3 @@
 MD5 4db63470575336e27f89038d7c7cc01e libebt-1.3.0.tar.bz2 144838
+RMD160 ad5def229f6b0166e929b51a0046eab17f744252 libebt-1.3.0.tar.bz2 144838
+SHA256 a375a51295a8417ba2fff8fdc3fefe84d39a56452e5a7345aacd5e0a01cba303 libebt-1.3.0.tar.bz2 144838
diff --git a/dev-cpp/libebt/files/libebt-1.3.0-as-needed.patch b/dev-cpp/libebt/files/libebt-1.3.0-as-needed.patch
new file mode 100644 (file)
index 0000000..7653dab
--- /dev/null
@@ -0,0 +1,32 @@
+--- libebt/Makefile.am.orig    2006-11-17 11:44:49.000000000 +0100
++++ libebt/Makefile.am 2006-11-17 11:47:28.000000000 +0100
+@@ -23,17 +23,15 @@
+ the_tests += libebt_boost_threads_TEST
+ libebt_boost_threads_TEST_SOURCES = libebt_boost_threads_TEST.cc $(test_headers) $(libinclude_HEADERS)
+-libebt_boost_threads_TEST_LDADD = libebttests.a
+-libebt_boost_threads_TEST_LDFLAGS = -lboost_thread
+-libebt_boost_threads_TEST_CXXFLAGS = -pthread $(AM_CXXFLAGS)
++libebt_boost_threads_TEST_LDADD = libebttests.a -lboost_thread
++libebt_boost_threads_TEST_LDFLAGS = -pthread
+ endif
+ if USE_ZTHREAD_TESTS
+ the_tests += libebt_zthread_threads_TEST
+ libebt_zthread_threads_TEST_SOURCES = libebt_zthread_threads_TEST.cc $(test_headers) $(libinclude_HEADERS)
+-libebt_zthread_threads_TEST_LDADD = libebttests.a
+-libebt_zthread_threads_TEST_LDFLAGS = -lZThread
++libebt_zthread_threads_TEST_LDADD = libebttests.a -lZThread
+ endif
+ if USE_PTHREAD_TESTS
+@@ -41,7 +39,7 @@
+ libebt_pthread_threads_TEST_SOURCES = libebt_pthread_threads_TEST.cc $(test_headers) $(libinclude_HEADERS)
+ libebt_pthread_threads_TEST_LDADD = libebttests.a
+-libebt_pthread_threads_TEST_LDFLAGS = -lpthread
++libebt_pthread_threads_TEST_LDFLAGS = -pthread
+ endif
+ TESTS = $(the_tests)
index 05e63e64ccce20738fdfb747bbf8fafeb0b5b586..bd452fc55b4f6e46ebb8e996d627132a006fe69c 100644 (file)
@@ -1,6 +1,11 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/libebt-1.3.0.ebuild,v 1.1 2006/01/26 13:15:49 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/libebt-1.3.0.ebuild,v 1.2 2006/11/18 10:36:47 dev-zero Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit autotools eutils
 
 DESCRIPTION="A pure C++ template library that provides a clean way of getting human-readable backtrace messages."
 HOMEPAGE="http://libebt.berlios.de/"
@@ -10,11 +15,20 @@ RESTRICT="primaryuri"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
-IUSE="doc"
+IUSE="doc test"
 
-DEPEND="doc? ( app-doc/doxygen )"
+DEPEND="doc? ( app-doc/doxygen )
+               test? ( dev-libs/boost )"
 RDEPEND=""
 
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${P}-as-needed.patch"
+       AT_M4DIR=m4
+       eautoreconf
+}
+
 src_compile() {
        econf || die "econf failed"
        emake || die "emake failed"
@@ -22,7 +36,7 @@ src_compile() {
 }
 
 src_install() {
-       make DESTDIR="${D}" install || die "make install failed"
+       emake DESTDIR="${D}" install || die "make install failed"
        dodoc ChangeLog README
        use doc && dohtml -r doc/html/*
 }