x11-themes/e-flat-theme: bump to 2020-03-01
authorJoonas Niilola <juippis@gentoo.org>
Tue, 17 Mar 2020 13:31:58 +0000 (15:31 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 17 Mar 2020 13:32:42 +0000 (15:32 +0200)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-themes/e-flat-theme/Manifest
x11-themes/e-flat-theme/e-flat-theme-0_pre20200301.ebuild [new file with mode: 0644]

index 805d5ced9cdeab601b432e06b9703858ee2f32de..2d8599c8d983b0d404d4306c6caea750855f1726 100644 (file)
@@ -1,2 +1,3 @@
 DIST e-flat-theme-0_pre20191230.edj 44142224 BLAKE2B 95d7431720f5b0ae3b2c1c96fd83264a02c5ee6758116ea44b0ae8260e79c73c06ad0d9461647f80b45caae6098b49b9152ac5a4f6fb7cf6f17119ed21ba7699 SHA512 6dfb1e1f6faaab7071829994c2ca82f68ff09a2a4c76a14311f55fe3238cb69c4563647c0434d880407e3d5eabbff3395591b3e3eeee8ac890a30bcfe281335b
 DIST e-flat-theme-0_pre20200216.edj 44070056 BLAKE2B df63fd32d0de42723fcb9c6d70d4d9a57d202f1d8b75d308d52e578b4374a3526a47d3fb4099b1b630081602897b562e7c0c3952fe80e9d649de34d770d8482a SHA512 4bf289c86e59e1a676792f0d9fd23b34cb6d81642a87ce3cd5a1097622b35aec72d9fb238873571b1ef8507972126918688f41879f7ce424ab7932da59860457
+DIST e-flat-theme-0_pre20200301.edj 45867392 BLAKE2B 1cdc143b2a6bca64d5e68b6a856c08520ef452d67d3aa2c0b0d25830821c773fe3cfaa773da3eff7a17b3f6c95be8af9b976ac16a0fa665be23fe4287d0c6d89 SHA512 664ae186c1ca7c804c9801077140d789fbce805adaf210e6094acf0c9515542af68c58b69b9344db0031a56a323666a05888ce66c816ab8af7c45096b8651490
diff --git a/x11-themes/e-flat-theme/e-flat-theme-0_pre20200301.ebuild b/x11-themes/e-flat-theme/e-flat-theme-0_pre20200301.ebuild
new file mode 100644 (file)
index 0000000..ef67789
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern, flat theme for Enlightenment WM"
+HOMEPAGE="https://www.enlightenment.org/ https://phab.enlightenment.org/T6726"
+SRC_URI="https://dev.gentoo.org/~juippis/distfiles/${P}.edj"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="x11-wm/enlightenment"
+
+S="${WORKDIR}"
+
+src_prepare() {
+       default
+
+       # doins doesn't allow installing straight from DISTDIR.
+       cp "${DISTDIR}"/${P}.edj . || die "Failed to prepare theme file."
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+       insinto /usr/share/elementary/themes/
+       newins ${P}.edj flat-0.edj
+}
+
+pkg_postinst() {
+       elog "You'll find e-flat-theme under System themes in theme selector."
+
+       if [[ -n ${REPLACING_VERSIONS} ]]; then
+               ewarn ""
+               ewarn "You're updating flat-0 theme. Please reload Enlightenment"
+               ewarn "through Menu -> Enlightenment -> Restart, or by issuing"
+               ewarn "  enlightenment -restart"
+               ewarn ""
+       fi
+}