dev-vcs/hg-evolve: Version bumps
authorCédric Krier <cedk@gentoo.org>
Tue, 18 Jun 2019 05:31:35 +0000 (07:31 +0200)
committerCédric Krier <cedk@gentoo.org>
Tue, 18 Jun 2019 05:31:54 +0000 (07:31 +0200)
Signed-off-by: Cédric Krier <cedk@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-vcs/hg-evolve/Manifest
dev-vcs/hg-evolve/hg-evolve-9.0.0.ebuild [new file with mode: 0644]

index 8014bb5302954f13fb8a456090e1acb087ac7214..9fa02efd7165812254168705dc6da74d0927d320 100644 (file)
@@ -1 +1,2 @@
 DIST hg-evolve-8.5.1.tar.gz 755965 BLAKE2B c9d6ea06f91cc537e1ea9266a09cded59e3dfb69f0bb5300a40b971bda6f9ce680c81978c23806972ca88931d9f2d67eedce14ba1f56670fa3c18194b63e2999 SHA512 7c5d9608d03ab81fc7291edb3f0ddb016cd4b267997bf66fcb221c9c917fbd34bfb4637bbb0c60b460a32304ee45fd7e30db929312dfbaa94df17baf7947482e
+DIST hg-evolve-9.0.0.tar.gz 757571 BLAKE2B 94b611c02def5fe386e39bd9c350a981d8278e7dc826318f67613111f3915f6bdb51cecb12fd3e308a317713e7716bfcee26f3292062aca2b9f154694bb7298b SHA512 4ce1fe0fbe58b9d260079ef588a74ef16d101b5080c8d72a80bfd7caa698ee7b0a1a9b2642ab20f0c8b7ba2d1a723c00aa3417b0a223fdf55f50bf7bfb940a2e
diff --git a/dev-vcs/hg-evolve/hg-evolve-9.0.0.ebuild b/dev-vcs/hg-evolve/hg-evolve-9.0.0.ebuild
new file mode 100644 (file)
index 0000000..a89ef7e
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="enables the changeset evolution feature of Mercurial"
+HOMEPAGE="https://www.mercurial-scm.org/doc/evolution/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+       >=dev-vcs/mercurial-4.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       doc? ( dev-python/sphinx )"
+
+python_prepare_all() {
+       rm hgext3rd/__init__.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs all
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       if use doc; then
+               dodoc -r html/
+       fi
+}