dev-python/bitstring: bump to 3.1.6
authorAndrey Grozin <grozin@gentoo.org>
Sat, 29 Feb 2020 10:50:30 +0000 (17:50 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sat, 29 Feb 2020 10:50:30 +0000 (17:50 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/bitstring/Manifest
dev-python/bitstring/bitstring-3.1.6.ebuild [new file with mode: 0644]

index 9f232f1026fb712ef01c3ded6bbf943920c137dd..ea2e90be4c11a521839167a695928a3e7bdb315f 100644 (file)
@@ -1 +1,2 @@
 DIST bitstring-3.1.5.tar.gz 761527 BLAKE2B 2e0c9ade6cd946bb777ee666d12c777191add1fdbb2c47fca097a0ee48cd8caa6eefb5dc1a4d69d9fbf986342759956bd2ed078043b1df7c482af54e25afc0fe SHA512 2c98768c98fc5ab99eeb4ac089ec66f091949e5e4f326563b1b480981ac2aa40258fe0065809eed9c08a71fae3cf09254a8a2465e86635db5287c0d2f241d75f
+DIST bitstring-3.1.6.tar.gz 751557 BLAKE2B e35735fac2f99832585e909b48faecec2c03f0bf41cb73d1eb1361269811c32a921c8f61762e107b2065adba38bbb40103e53909ed14dd84814eb323b73bc911 SHA512 d78d91f92f60044948199e4fa5ec48c8007268f725e5230d6c8be44a6ced578e61a2c2f8751822f191a909057f38d358a8c944f357a5f9ea98adb6baae3a0da2
diff --git a/dev-python/bitstring/bitstring-3.1.6.ebuild b/dev-python/bitstring/bitstring-3.1.6.ebuild
new file mode 100644 (file)
index 0000000..48cce38
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="A pure Python module for creation and analysis of binary data"
+HOMEPAGE="https://github.com/scott-griffiths/bitstring"
+SRC_URI="https://github.com/scott-griffiths/${PN}/archive/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}-${P}
+
+DOCS=( README.rst release_notes.txt )
+
+python_test() {
+       pushd test >/dev/null || die
+       "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+       popd >/dev/null || die
+}