dev-util/hadolint: Version bump to 1.7.1
authorManuel Rüger <mrueg@gentoo.org>
Mon, 11 Jun 2018 10:13:39 +0000 (12:13 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Mon, 11 Jun 2018 10:13:39 +0000 (12:13 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-util/hadolint/Manifest
dev-util/hadolint/hadolint-1.7.1.ebuild [new file with mode: 0644]

index 5373b714b489b66336099a9af716bbe06966dd0c..e28300b37920579c22e12c321bc3e1ff4060d2fc 100644 (file)
@@ -1,2 +1,3 @@
 DIST hadolint-1.5.0.tar.gz 31002 BLAKE2B 889885192f8ae12c468b90923948970d617bb5dc0156efa615e8ef750b3940b66d84215a21d0dca11ee7176f12b32c47a35a763035c9c2023bb8dc83b2b0af69 SHA512 19e246d82670e27751729394ba73ef03260525eedb0dbe26a605dd2c30e95386bafb85f9063a94d3a3e8b47fb05c248bdd6fda0ef9cf95285b1ec0ef54ad6d15
 DIST hadolint-1.6.1.tar.gz 32674 BLAKE2B b7b3bc664848806d2316053724a91d0276e8af8c0324b31c2b3c2ae48b247e2092473170bc0f8ffcd76cf3b91e3c17e0e9b7b5f47c1eb416d23d01b29b454182 SHA512 ed79861d0938327ebeac8a8162d3a76257a22829d6188512bb43d5312327e39f31ff960d85e7d5c367a377c0a21e7df637e6d40448415752f132cf385ab8bfa2
+DIST hadolint-1.7.1.tar.gz 33520 BLAKE2B e66b76135c0b69a906e8a4cb0f08b9eb53e8c5d15140f20c31894155cfdc97cdc2899f1bbf575fdbed9feea99884d88b604d0bdfd2daeed4efd6064a9e28e453 SHA512 44e952665a3fbd592397cfb251935f0129900c5c87f34dc884cdb83e668e369848c0c0c403f8d7f31fd786de84e64b5e8df4d3935309acfe8266d5621f7966de
diff --git a/dev-util/hadolint/hadolint-1.7.1.ebuild b/dev-util/hadolint/hadolint-1.7.1.ebuild
new file mode 100644 (file)
index 0000000..ee88be7
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Dockerfile Linter JavaScript API"
+HOMEPAGE="https://github.com/hadolint/hadolint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+       >=dev-haskell/gitrev-1.3.1:=[profile?]
+       >=dev-haskell/language-docker-6.0.1:=[profile?] <dev-haskell/language-docker-7:=[profile?]
+       >=dev-haskell/megaparsec-6.4:=[profile?]
+       >=dev-haskell/optparse-applicative-0.14:=[profile?]
+       >=dev-haskell/split-0.2:=[profile?]
+       dev-haskell/text:=[profile?]
+       dev-haskell/void:=[profile?]
+       dev-haskell/yaml:=[profile?]
+       >=dev-lang/ghc-8.0.2:=
+       >=dev-util/shellcheck-0.5.0:=[profile?]
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.24.2.0
+       test? ( dev-haskell/hspec
+               >=dev-haskell/hunit-1.2 )
+"
+
+src_prepare() {
+       default
+       sed -i -e "s/-static//" ${PN}.cabal || die
+}