dev-python/pslab-python: support python3_7
authorMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 15:48:49 +0000 (16:48 +0100)
committerMarek Szuba <marecki@gentoo.org>
Tue, 21 Apr 2020 15:51:52 +0000 (16:51 +0100)
Also make better use of distutils-r1 and make Python dependencies
actually sane (no idea what I was on when I committed that).

Nb. having had a look at upstream CI this *should* work with 3.8 as
well, will have to add support for this version to dev-python/pyqtgraph
first though.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-python/pslab-python/pslab-python-1.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pslab-python/pslab-python-1.0.1-r1.ebuild b/dev-python/pslab-python/pslab-python-1.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..71659cc
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with Pocket Science Lab"
+HOMEPAGE="https://pslab.io"
+SRC_URI="https://github.com/fossasia/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+       $(python_gen_cond_dep '
+               dev-python/numpy[${PYTHON_USEDEP}]
+               dev-python/pyqtgraph[${PYTHON_USEDEP}]
+               dev-python/pyserial[${PYTHON_USEDEP}]
+               sci-libs/scipy[${PYTHON_USEDEP}]
+       ')"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.0.1-sys_version.patch
+       "${FILESDIR}"/${PN}-1.0.1-no_install_udev_rules.patch
+)
+
+distutils_enable_sphinx docs