dev-ros/rosbag: Bump to 1.13.1.
authorAlexis Ballier <aballier@gentoo.org>
Sun, 30 Jul 2017 16:10:15 +0000 (18:10 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 30 Jul 2017 16:43:45 +0000 (18:43 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-ros/rosbag/Manifest
dev-ros/rosbag/rosbag-1.13.1.ebuild [new file with mode: 0644]

index 4fae18ea57e6d5bf105c15d2b5736e046e07baee..5a1ca4a2b02524c914b5efac08236d3e4797f9b4 100644 (file)
@@ -1 +1,2 @@
 DIST ros_comm-1.13.0.tar.gz 974811 SHA256 01eee591e0462e267da5c01537faf609c11497b578d4426818919514a8589ea6 SHA512 8cd0f8cb40d51293946a87da0614921150aa87d168e0d38981f0b7eef3c0f514f14ff613efd192c9c898b3a90fedd0cba21a9f337a197377fd946f427369c60b WHIRLPOOL 6054aca71a7afb0a202b2b8e7baf9b06c51e41f86da0959909bfe130a63a88c684a385b7ef6f9ed8ce2c7c766d6ef78ef83fd8bd97b0cc519717087050122307
+DIST ros_comm-1.13.1.tar.gz 1005522 SHA256 da0797365fb88a41005219079bd034e7e04218b75f28d0275d6e5327be3bc903 SHA512 92248a91d7b7b6defd8607d70e5a09c43c9bc242cfc5574acd5b08c3f9b765144c848c0f72551bb2e19789a345c31f43ed420a9e3e7fbe38bf47adeb7c52a9d7 WHIRLPOOL 746e56a5ebc9e500eb7e333c88259aa20d7685930f30a8bf71982f1cef9c7c14ac28d758adbd13d89b66ca6e1ec01816ce6541fe8817b188bf05e3f477914a4a
diff --git a/dev-ros/rosbag/rosbag-1.13.1.ebuild b/dev-ros/rosbag/rosbag-1.13.1.ebuild
new file mode 100644 (file)
index 0000000..cdf7eef
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE="lz4"
+
+RDEPEND="
+       dev-ros/rosbag_storage
+       dev-ros/rosconsole
+       dev-ros/roscpp
+       dev-ros/topic_tools
+       dev-ros/xmlrpcpp
+       dev-libs/boost:=
+       app-arch/bzip2
+       dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/roslib[${PYTHON_USEDEP}]
+       dev-ros/genpy[${PYTHON_USEDEP}]
+       dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+       lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"